FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
539 views 0 comments
by

Hi, 

My RUT240 has a SIM card without a public IP address (behind NAT gateway). I am building a workaround, to be able to remotely access the modem. To do that, I am trying to connect it to an OpenVPN server on AWS as a client, and then connect my computer as a client to that server as well.

I exported the OpenVPN profiles from the server and imported the .ovpn file in the RUT240. This works, the RUT240 can successfully connect to the server. 

Now, I can ping my computer from the RUT240, I can ping the OpenVPN server. However, I cannot ping the RUT240 from my computer. When I connect my computer to the RUT240 via wifi, I also cannot ping the server or the other client (it has to be done via the Teltonika GUI).

I am pretty sure it has to be a firewall setting on the RUT240, as I also tested the Teltonika OpenVPN profile on other hardware, and in that case I am able to ping the server and client. 

1 Answer

0 votes
by anonymous
Hi,

If you’re connecting your PC to RUT240 via Wi-Fi there’s no need to use VPN as both devices are in the same network. If both RUT240 and your PC are configured to use AWS VPN server as default gateway, there might be routing/NAT issues if you try to access device while PC is connected to RUT240 Wi-Fi network.

Could you as well share your OpenVPN server configuration, is client-to-client option enabled?

Also there’s no need to change Zone Forwarding options on RUT240, default settings should allow VPN client-to-client reachability.

Can you share the troubleshoot file of your RUT240, it can be downloaded in WebUI → System → Administration → Troubleshoot.