FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
1,300 views 4 comments
by anonymous

Hello,

I have an issue with my VPN setup. I use a RUT955 with the latest firmware and my VPN provider is NordVPN. To connect to NordVPN I just followed the config example in the wiki. It looks fine in the RUT955 UI. I get connected and in the diagnostics part I can test it with e.g. www.google.com etc. I see the VPN IP 10.xx.xx.xx and the VPN Server IP.

But if I want to connect with my android tablet I get no connection a all. I can access the WebUI of the RU955 but that's it.

Has someone seen something like this before?

Thanks for any tips!

Cheers

Dirk

1 Answer

0 votes
by anonymous

Hello,

please follow these steps from beginning to use NordVPN:

  1. Create new VPN client instance for NordVPN. How to is explained in this page: https://wiki.teltonika-networks.com/view/Anonymous_browsing_from_your_home_network_using_NordVPN_and_RUT9xx_router#Home_network_configuration_.28RUT9xx.29
  2. Set DNS server settings on RUT for mobile WAN interface:

·        go to Network > WAN, there click Edit on a mobile WAN.

·        Disable DNS servers advertised by peer

·        Add first DNS server: 103.86.96.100.

·        Add second DNS server: 103.86.99.100.

·        Press Save.

3.Connect into RUT device CLI or SSH interface and enter this commands:

root@Teltonika-RUT955:~# uci set firewall.vpn_zone.device='tun+'

root@Teltonika-RUT955:~# uci commit firewall

root@Teltonika-RUT955:~# luci-reload

root@Teltonika-RUT955:~# /etc/init.d/firewall reload

root@Teltonika:~# reboot

Router will reboot and after that anonymous browsing should be OK.

If issue reappears download troubleshoot file on menu System > Administration > Troubleshoot and send it to me via private message.

Regards.

Best answer
by anonymous

Hello,

thank you for your answer. Now erverything works fine smileyyes

Cheers

Dirk

by anonymous
Hi.

Will this work on the RUTX11.

I have NordVPN and want to set it up?

Thanks Carl
by

Could you please explain what uci set firewall.vpn_zone.device='tun+'  command do?

Many thanks

by anonymous

This input modifies /etc/config/firewall file by adding the 'tun+' value:

config zone
        option device 'tun_+ tun+'
        option name 'openvpn'
        option masq '1'
        option input 'ACCEPT'
        option forward 'REJECT'
        option network 'openvpn'
        option output 'ACCEPT'

This should be done if the firewall is blocking OpenVPN traffic.

As far as I know this has already been fixed and with new firmware versions this additional setup is not required.