10855 questions

12932 answers


25357 members

0 votes
1,972 views 5 comments


l just enabled SNMP on my RUT240 (at least a can see it is running in UI), but it seems that the router is not responding to my snmwalk requests:

SNMP server IP address:

RUT240 IP is:

root@Debian-Jessie-8:~# snmpwalk -v1 -c public (default community on both ends)

1 Answer

+1 vote


Tried using same RUT240 firmware version, which you are currently using (RUT2XX_R_00.01.04.1) and "MIB Browser" SNMP application and everything is working without any issue.

I.e., router's configuration:

"MIB Browser's" configuration:

SNMP Walk correctly returns all IODs values:

Could you let me know more details how your "SNMP Server" is connected to the router? Since their IPs are from different networks, does that mean that your "SNMP Server" ( is connected to RUT240 "remotely" (via WAN interface)?

Do you have an option to reset your RUT240 to factory default settings, enable SNMP once again, then connect your "SNMP Server" directly to router's LAN and try to get information from the router this way? Does this allow you to read information from the router? If no, have you tried using different SNMP applications (it might help to determine if it is router's or application's issue).

Best answer
Thanks! RUT240 IP is reachable via IPSec VPN. Weird. tcpdump shows that the queries reach the router but there is no response. I will try direct snmpwalk once gain TeamViewer access to the local PC. How do l check if SNMP process is running on RUT with CLI? Can the device be queried via SNMP across the IPSec tunnel?


Just tested RUT240's SNMP via IPsec tunnel and can confirm that for you, that everything should be working without any issue. Just take note, that connection from VPN is interpreted as "remote connection". Therefore in RUT240 SNMP's configuration you should enable "Enable remote access" checkbox. During the test I used this simple topology:

And successfully retrieved SNMP's information from "PC" by connecting to "".

You can check processes, which are running on the router, with "ps" CLI/SSH command. Process, responsible for SNMP is called "snmpd". You can also filter the results with additional "grep" option ("ps | grep snmpd"):


Thank for your help here. I have followed your suggestions, still no luck. Ok, l can also confirm SNMP works fine with the exact same setup but with the RU500. So l have two VPN tunnels: one to RUT240 another one to RUT500. Must be something with device`s setting .. as l still struggle to get my check_mk to query the device successfully, only custom checks (.e.g SSH, PING work):




by the way, my CLI/UI outputs:



Happy days! For some reason (even UI was displaying that the process was running), it actually was not, CLI was showing the opposite.

I started the process manually and check_mk now able to pull some data from the unit:

Thanks for all way through.