subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
603 views 1 comments
by anonymous
I seem to have some hosts on my LAN that doesn't send their hostname when asking the DHCP-server for an IP-address. So therefore I have alot of entries with hostname "?" in the DHCP Leases list.

One easy fix is to reserve IP-address for the offending hosts, but then you have the problem that you need to write down the mac-address and then enter it manually.

One suggestion is to have a "add static lease" button on the DHCP leases list, and it will ask for what you want to name the device.

I like to have my dhcp using as much dynamic hosts as possible to avoid ip-conflicts. The way I solved it was to give dnsmasq a hint of what the host is named and the IP-address will be given automatically.

So I just added entries like this to my /etc/dnsmasq.conf on the router:


It seems however that the static entries added directly in the file doesn't show in the gui.

1 Answer

0 votes
by anonymous


There is option to add static DHCP leases, but as you said, you have to point out MAC address, as the DHCP server will otherwise not know whom should it give the IP address to. Does the hostname show up properly when you add a static DHCP lease to the device?

Also, you don't have to enter the MAC address manually. If the device is connected to the network you can just choose its MAC address from the list.

Regarding dnsmasq file entries and GUI, some of the entries and changes to the files do not represent on the page as they work separately.


by anonymous

When adding a entry manually in the dnsmasq.conf file the hostname is shown properly in the DHCP lease list.

I have a different layout on my Static lease list, I need to first select a name and then get a new page with hostname, mac and IP, and no help getting the data entered as you show.

I'm on the RUTX11 device.

I just have first an input box to enter a descriptiive name:

And then clicking "Add" I get this screen:

I was a bit unclear about that the manually static entries doesn't show, I have added a static entry for, and it didn't show in the list until that specific host requested an IP.

I have another static entry for, but that host is set to static IP due to its DHCP-client being buggy (SD-card wifi) and that entry doesn't show in the GUI now after spending the night with the setting.