FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
1,205 views 1 comments
by anonymous
When creating an OpenVPN client, the input field for the password of the private key is missing.

1. Enable OpenVPN config from file

2. Enable

3. Upload OpenVPN authentication files

4. disabled Use PKCS # 12 format

5. select all files

6. Save

Error message: Client key is encrypted, please enter decryption password

But there is no input field for it.

1 Answer

0 votes
by anonymous

Hi,

There is no possibility at this moment to insert password to decrypt the certificates/keys through WebUI.

You can insert the “askpass” option into your OpenVPN file directly, usage example:

askpass /etc/openvpn/pass.txt

Note that the file must be in the router.

EB.

by anonymous
Here is my workaround.
Disable OpenVPN config from file.
The input field for the password to decrypt appears. Configure it however you want.
Enter the password.
save.
The configuration can then be changed back to Enable OpenVPN config from file. Don't forget to save.