8314 questions

9778 answers

15559 comments

13902 members

0 votes
535 views 8 comments
by

Hi all.

If i send this request (http://217.141.186.86:800/cgi-bin/sms_send?username=user1&password=****&number=****&text=ABCD) through a LAN pc (192.168.43.128) in the same network of RUT950 (192.168.43.254) it is successful but if i use ax external PC (other network) to make the same request it goes timed out.

Do you have an idea? 

SMS Gateway (RUT950 with IP 192.168.43.254:80) is behind a firewall (217.141.186.86:800) with port forwarding.

3 Answers

0 votes
by
Hi,

Could you confirm that you can connect to your WebUI through that public IP that you're using in the link of HTTP GET request? Please try to connect from the external network.

EB.
0 votes
by
Hi.

I can't connect to http://217.141.186.86:800 to reach webUI
by
Then it means something in your firewall goes against your rule. Please check your firewall settings is there anything that might block outcoming WAN to LAN connections. Additionally, you can enable Remote HTTP access in System > Administration > Access control.

EB.
by

Firewall seems to be configured correctly in fact  the external request connection (http://217.141.186.86:800) reaches RUT950 as you can see attached.

It seems that RUT950 can't reply correctly

.

I've just activated http remote access on port 80 as above described.

by
Could you please send me your troubleshoot file?

Thank you.

EB.
0 votes
by
by
Please download the troubleshoot file from System > Administration > Troubleshoot and send it to me via private message.

EB.
by
there's no file
by

Is this option not available to you?

by
Yes, but .rar file is empty
by

I just solved inserting routing rules in RUT950 via CLI.

echo 200 reth0 >> /etc/iproute2/rt_tables
echo 201 reth1 >> /etc/iproute2/rt_tables
ip rule add from 10.107.134.176 table reth0
ip route add default via 10.107.134.177 dev wwan0 table reth0
ip rule add from 192.168.43.254 table reth1
ip route add default via 192.168.43.1 dev br-lan table reth1