3753 questions

4659 answers

7016 comments

4868 members

0 votes
68 views 5 comments
by
Can you provide a walkthrough of using wifi as wan on rut950 and confirm whether you can run a hotspot at the same time as using a wifi wan?

Thanks

1 Answer

0 votes
by

Hi,

Yes, the Hotspot should work alongside WiFi WAN. Just make sure that the Hotspot's and your router's LAN IP ranges are not in the same subnet as the WiFi AP that you'll be using as WAN.


To set up WiFi as WAN:

  1. Log in to your router's WebUI and go to the Network → WAN page.
  2. Set WiFi as 'Main WAN' and click 'Save'. Or set 'WAN Failover', depending on what you need, as long as there's a checkmark next to WiFi in that window.
  3. Wait a bit (the WAN page is the slowest one to apply changes, so it may take a minute) and click the 'Scan' button when it appears next to the WiFi WAN interface.
  4. Select a WiFi AP to connect to.
  5. Enter the password (if required) and click 'Save'.

And it should be done. If all is well, you should see an IP address next to the WiFi WAN interface if you go back to the Network → WAN page.

Good luck,
DM

ago by
Hi,

Thanks for your prompt response.

Your walkthrough matches the steps I was taking.

On the status>overview page WAN IP is still N/A

On the network>wireless page it shows the wireless station mode as connected to the wifi wan provider and the lan access point wifi is on as well

WAN is set to WIFI with no failover set

I tried reseting the RUT950 to factory and it still doesn't work

Any help appreciated

Thanks
ago by

Sorry to hear that.

Could you reboot the router, walk through the steps again (while the router is configured as usual) and download the Troubleshoot file after a couple of minutes? It can be downloaded from the System → Administration → Troubleshoot page.

Then please send it to me via private message (you'll need an account on this forum for that, though). Or you can share it by your preferred method, but take note that the Troubleshoot file may contain sensitive information. It hold the routers logs and configuration files. Keys and passwords are not visible because they're hashed, but if you've added phone numbers, emails to your configuration or if you have a public IP address it all shows up in the Troubleshoot.

DM

ago by
PM sent from sidewinder

Thanks
ago by

Hi again,

I received the file, thank you. This situation is definitely atypical. I couldn't reproduce it with my equipment so, I started looking at what could cause the entries in the system.log

First, there is a strange option in the wireless config, sta interface section (excerpt from /etc/config/wireless; abridged):

config wifi-iface
 option network 'wan'
 option device 'radio0'
 option user_enable '1'
 option mode 'sta'
 option disabled '1'

The highlighted options are contradictory; I suggest removing option disabled '1'. Since it is unclear how it got that way, you'll have to remove it via SSH/CLI. Simply log in and execute these commands in order:

uci delete wireless.@wifi-iface[1].disabled='1'
uci commit
wifi

(first one deletes the option, second commits changes, third restarts WiFi.)


Another thing I noticed in the logs is that the other access point is possibly ignoring the authentication requests from the RUT950, as indicated by these timeouts (excerpt from system.log; I just added dummy MACs and SSIDs):

daemon.notice wpa_supplicant[20366]: wlan0: SME: Trying to authenticate with 00:11:22:33:44:55 (SSID='Your_router' freq=2462 MHz)
kern.info kernel: [23504.450000] wlan0: authenticate with 00:11:22:33:44:55
kern.info kernel: [23504.470000] wlan0: send auth to 00:11:22:33:44:55 (try 1/3)
kern.info kernel: [23504.590000] wlan0: send auth to 00:11:22:33:44:55 (try 2/3)
kern.info kernel: [23504.700000] wlan0: send auth to 00:11:22:33:44:55 (try 3/3)
kern.info kernel: [23504.810000] wlan0: authentication with 00:11:22:33:44:55 timed out

I suggest reviewing that router's WiFi AP policies (MAC filter perhaps or blocked because of unsuccessful authentication attempts?)

If you can't find anything on the other router, you can try changing the WiFi Mode to 802.11g on the RUT950. This can be done from the Network → Wireless → Edit → Advanced Settings page. The reason I'm suggesting this is because I suspect the Access Point is a Ubiquiti router? I'm asking because I found some evidence on the Internet that there could be some sort mismatch with this software and Ubiquiti's and disabling the n mode might help.

I hope some of this will prove helpful. I look forward to hearing your feedback.

DM

ago by
Hi,

I have completed the cli steps and set the router to 802.11g but the problem with that particular WAN connection continues.

I connected the RUT950 to another WIFI so I think what you say about the configuration of that particular remote station is accurate. The remote station I am having problems with is not mine so I cannot alter that configuration.

I have sent another file to your PM, could you confirm that I have followed your steps correctly?

Thanks