FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
1,438 views 10 comments
by

I noticed that at the change of ip from the manager of the sim (iliad) the modem despite being in operation does not give access to the internet. To solve the problem I have to restart the rut240.

FWver: RUT2XX_R_00.01.12.3

12 Answers

0 votes
by anonymous
Hi,

It is a bizarre issue as our routers shouldn't kill the connection even if you have a dynamic IP that is constantly changing.

I would suggest setting a custom APN provided by your operator and see if you remain the connection even after IP change. Most of the time APNs are documented on operator websites, so you could start with looking for it there and if you're not able to find it - call them.

EB.
by

I set the APN manually but the same thing occurred

0 votes
by anonymous

Hello, some more options to handle mobile connection is available under

Network > Mobile Tab.

Like Force 4g or Re register every n seconds, are you try to set  this options?

Will be a configuration mistake, you can try to set differents combinations but the first thing when request advices, is posting your configuration tests and your logfiles from

System > Administrator Troubleshoot tab.

Here you can select verbosity of logfiles (set INFO will be enough for starting debug)  and include (checkmark) all gsm/pppd/modem performing actions into log (System and Kernel) files.

After adjust and SAVE troubleshoot tab, you are ready to dump "errors", wait a while and get a look on your logs, post here as well.

This information will help much more to diagnostic issue, than a human description meow heart

Also you can grab acutal configuration easy, by downloading support files (Troubleshoot files button)

Hope this will be helpful! A side note, my rut240 after firewall fine tuning works smooth and faster like a rocket laugh

0 votes
by anonymous


as required I attach the support files.
Thanks for your help

https://community.teltonika-networks.com/?qa=blob&qa_blobid=9904536883181994617

by anonymous

Hi,

Please download troubleshoot file when your operator changes sim and you lose connection to the internet. As it is now, your log-read is fully empty because the troubleshoot file probably was downloaded right after you turned on your router.

EB.

0 votes
by anonymous
Hello, I downloaded the list before restarting it. I noticed a strange thing, but I don't know if it is connected. After inserting the configuration file of ipstatico.org to access the internet from the PCs, I had to enter the dns manually, otherwise it didn't work. I don't want the two to be connected.
0 votes
by anonymous

I get a brief look on your configuration, I see under network:

config interface 'ppp'
    option enabled '1'
    option backup '1'
    option metric '10'
    option cid '1'
    option service 'auto'
 So first of all ensure you set MAIN WAN to mobile connection (Network > WAN) as shown below:

Regards

by anonymous

I configure the wan as you indicated it disconnects. To work I have to put it as follows. I do not know why?

by anonymous

I configure the wan as you indicated it disconnects. To work I have to put it as follows. I do not know why?

Ouch, strange, I set MAIN WAN on my RUT240 without issue,
first is need to uncheck wan failover thik from mobile, then save configuration;
second is to select mobile as main then save, and perform reboot for start with fresh configuration;
third you can optional reorder connection list by pressing on up arrow to the right side of mobile line.
Keeping failover disabled if no cable wan is connected as well.
0 votes
by anonymous

Hi, additional I look at your routing table configuration:

[Routing table]
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         10.8.0.1        128.0.0.0       UG        0 0          0 tun0
0.0.0.0         10.14.46.229    0.0.0.0         UG        0 0          0 wwan0
10.8.0.0        0.0.0.0         255.255.255.0   U         0 0          0 tun0
10.14.46.224    0.0.0.0         255.255.255.248 U         0 0          0 wwan0
10.14.46.229    0.0.0.0         255.255.255.255 UH        0 0          0 wwan0
128.0.0.0       10.8.0.1        128.0.0.0       UG        0 0          0 tun0
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 br-lan

Shows openvpn tunnel routing subnet maybe generate "confusion" with iliad gateway subnet, so by this reason I advice to reconfigure your openvpn tunnel and change it's subnet from 10.8.0.0/24 to another class C/D network like 192.168.x.x or 172.16.x.x

I think for openvpn misconfiguration, if you can , better you try iliad connection stability with RUT240 defaults restored, from a resetting and rebooting device trought wizard configuration without any other changes. Don't forget to make configuration backup for reference later you can merge some specific section of old configuration if you want to  do.

If iliad link is steady, after first initialazing of your RUT240 you found the way to go, :D set main wan as mobile, disable failover,  and disable IPv6 support if not needed, save your configuration in safe, then rebuild your openvpn tunnel.

Regards

0 votes
by anonymous

before enabling the openvpn network everything works as you indicated. I attach the tunnel configuration screen. I can't get the Remote network IP address data saved

by anonymous

Hi,

It might be a save validation error. Try this:

  • Change one drop-down menu selection, let's say protocol and then type in your Remote host/IP address - Save and once it's saved and you see that Remote host/IP address field is filled you can change your protocol back to what it was.
  • Another way to do this would be going through CLI and changing it in config directly:
First make sure you enabled openvpn client by clicking on checkbox next to Enable.

1. Navigate to /etc/config/ folder of your router with cd /etc/config

2. Open openvpn config with command: vi openvpn

3. To start editing the file press letter " i " on your keyboard

4. Find option called: option remote or if it doesn't exist write it under other options of the client as: 

option remote 'changeThisToYourRemoteIP'

5. To exit editing press ESC on your keyboard and write :wq

6. Check if it's saved with cat openvpn

You can restart the router after this just to make sure everything loads correctly and you should be able to have an active tunnel if it's all correct in your configuration and certificates.

EB.

0 votes
by anonymous
I tried to modify the data as you said but it doesn't save them. in the CLI I cannot enter it tells me incorrect password, but I am sure it is that.
by anonymous
Could you please post a screenshot of where you get this "incorrect password" output from?
0 votes
by anonymous
is it normal that when I type the password I don't see the characters?



by anonymous

Yes, it is normal.

First of all your login name should be root when you connecting from CLI.

And then you need to type your password, it will not show anything, but believe me it's there. Type your password and just press enter.

0 votes
by anonymous

I am attaching the screenshots

by anonymous
Have you managed to get your OpenVPN working?