FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
810 views 1 comments
by anonymous
I used to use mosquitto_sub on the RUT955. I installed it with

opkg install mosquitto-client

But since don't know when I cannot use it anymore. I get a "Unknown package 'mosquitto-client'." error.

What happened? I didn't even update the firmware.

2 Answers

+1 vote
by anonymous

Hi,

Execute opkg update first. This updates the package list and should make mosquitto-client available for download.

DM

Best answer
by anonymous
I have the version RUT9_R_00.07.00, and the command OPKG UPDATE not work, and mosquitto_pub not work

Show the package is not available or some like
0 votes
by anonymous

On the RUT240 I updated to the latest firmware (RUT2_R_00.07.03.4) and installed the MQTT package from Package Manager (http://192.168.1.1/services/packages/packages or https://wiki.teltonika-networks.com/view/RUT240_Package_Downloads). 

Then on the terminal I did the following: 

opkg update

opkg install mosquitto-ssl

opkg install mosquitto-client-ssl libmosquitto-ssl

thanks to: https://www.onetransistor.eu/2019/05/mosquitto-mqtt-on-openwrt-router.html