subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
501 views 1 comments
by anonymous

RUT955 properties:

Firmware version


Build Date

2020-03-13 09:37:25

Kernel version


Bootloader version


After installing "USB Tools" via Package Manager I tried to configure SAMBA Shares.

I invoked "Services>USB Tools", tab "Mounted file systems".

Under labels "Filesystem" I found "/dev/sda1", under "Mount Point" "/mnt/sda1", under "Available" "26.77 GB / 28.20 GB", under "Used" "0% (20.00KB)"; so my SanDisk 32GB ext2 USB stick is correctly mounted.

I selected tab "Samba user". I configured a user under label "Username" and gave it a password under label "Password", then pressed button "Add". The new user appeared under label "Username".

I selected tab "Samba". I enabled Samba via checkbox "Enable", entered a "Hostname"="RUT955_Share", a "Description" and a "Workgroup".

Then I pressed button "Add" and added a share with "Name"="Books", "Path"="/mnt/sda1", "no guest", "Allowed users"="user from above", "no read only"; I pressed button "Add" a second time and added a share with "Name"="Music", "Path"="/mnt/sda1", "guest".

I pressed button "Save".

In WINDOWS explorer I can see the network resource "RUT955_Share". When trying to open it I had to enter my credentials (Username and Password of RUT955 WebUI). Then I could see my two folders, "Books" and "Music". When trying to open "Books" I had to enter user's credentials; I selected those from the user under tab "Samba user". A WINDOWS dialog opened with: "No access to \\RUT955_SHARE\Books ..." and so on. Opening "Music" works.

I connected my mobile phone to RUT955 WiFi at LAN, opened an app "AndSMB" and could see the "RUT955_Share", beneath two folders "Books" and "Music". Trying to open "Books" failed also in this application, while opening "Music" worked.

I do not understand this behaviour. Maybe that something's wrong with my configuration, but I do not think so, because it's really straight forward. Are there any restrictions to selecting "Password" or "Username" I do not know?

Any help is totally welcome.

Thanks in advance!

by anonymous

The problem was the following:

When trying to access the SAMBA share, a WINDOWS dialog (Windows-security) was asking for a password. In RUT955 for the SAMBA share I had configured the same password as for my WINDOWS login credentials. My WINDOWS password contains a special character which for any reason has not been accepted either by the WINDOWS security dialog or by RUT955 share.

Then I configured another user and password in RUT955 while in Windows security dialog using the option "Use another account". This worked, but not in all cases.

Finally, together with Teltonika, I checked and tested the allowed character set for RUT955 SAMBA shares with the following result:

Allowed standard characters: A-Za-z0-9

Allowed special characters: !@#%&*+-/=?^_{|}~$`

Yet, in my tests, $ and ` still did not work; the reason is unknown (either WINDOWS restrictions or RUT955 restrictions).

So, in a nutshell, SAMBA shares are working well, but one has to care about using special characters for passwords.

1 Answer

0 votes
by anonymous
Hello, Guenther!

Is it possible for you to send me a troubleshoot file in PM?

You could find it in WebUI -> System -> Administration -> Troubleshoot.

Best regards, Aliaksandr!