5276 questions

6429 answers

10373 comments

6439 members

0 votes
202 views 3 comments
by
Hi. As mentioned in the subject, router says it's connected to the internet (e.g. in network topology) but whichever device I connect via WIFI has no internet access. I've tried multiple different SIM cards (various operators).

Could you please help?

Thanks.
J

1 Answer

0 votes
by

Hi,

Could you check these options:

  • Check if in firewall source zone you see your access point next to eth0 interface and the whole zone is set to default forwarding action - accept.
  • Check your wireless access point configuration. Make sure the channel is set to auto and in advanced tap everything is set to it your devices would support it. You can also change the country code to yours or if it's set to yours - change it to world.
  • Below you will see "Interface configuration", check if you do not have MAC Filter enabled.
  • Check if your wireless clients when connected get the same subnet IP addresses, try to ping them from the routers CLI.
  • To make sure it's not a firewall issue you can execute this: /etc/init.d/firewall stop in your CLI and disable the firewall. You can start it back on later with /etc/init.d/firewall start 
EB.
by

Hello. Thanks for your answer. Please see my comments.

Check if in firewall source zone you see your access point next to eth0 interface and the whole zone is set to default forwarding action - accept.

Yes, all INPUT, OUTPUT and FORWARD are set to ACCEPT.

Check your wireless access point configuration. Make sure the channel is set to auto and in advanced tap everything is set to it your devices would support it. You can also change the country code to yours or if it's set to yours - change it to world.

Channel is set to AUTO and I've changed country code to mine.

Below you will see "Interface configuration", check if you do not have MAC Filter enabled.

MAC filter is disabled.

Check if your wireless clients when connected get the same subnet IP addresses, try to ping them from the routers CLI.

I can ping the connected device from router (connected via SSH).

To make sure it's not a firewall issue you can execute this: /etc/init.d/firewall stop in your CLI and disable the firewall. You can start it back on later with /etc/init.d/firewall start 

/etc/init.d/firewall stop throws

Warning: Unable to locate ipset utility, disabling ipset support
Warning: Section 'vpn_zone' cannot resolve device of network 'vpn'
Warning: Section 'l2tp_zone' cannot resolve device of network 'l2tp'
Warning: Section 'pptp_zone' cannot resolve device of network 'pptp'
Warning: Section 'gre_zone' cannot resolve device of network 'gre'
Warning: Section 'hotspot' cannot resolve device of network 'hotspot'
Warning: Option @rule[14]._name is unknown
Warning: Option @rule[15]._name is unknown
Warning: Option @rule[16]._name is unknown
Warning: Option @rule[17]._name is unknown
 * Flushing IPv4 filter table
 * Flushing IPv4 nat table
 * Flushing IPv4 mangle table
 * Flushing IPv4 raw table
 * Flushing IPv6 filter table
 * Flushing IPv6 mangle table
 * Flushing IPv6 raw table
 * Flushing conntrack table ...
Command failed: Not found
I've ended up flushing iptables manually and now they are set as follows:
root@Teltonika-RUT850:~# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination
Chain FORWARD (policy ACCEPT)
target     prot opt source               destination
Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
However, I still cannot access internet from the connected device, e.g. 
ping google.com
Pinging google.com [216.58.208.174] with 32 bytes of data:
Request timed out.

The DNS seems to work though.

Shall I provide the troubleshoot file?

Regards,
J.

by
Could you factory reset all the settings? Then try connecting your devices again and only then download troubleshoot file.

You can send me your troubleshoot file via private message.

EB.
by
Hi. I've reset to factory settings and run the config wizard again. Now the WIFI connected devices can access the internet. Issue solved.

Thanks for the advice.
J