7877 questions

9301 answers

14976 comments

12781 members

0 votes
242 views 4 comments
by
Hi there!

I recently got my RUTX10 and I'm impressed by its features and build quality. However, there is one strange issue: When I use it in WiFi Client mode, outgoing traffic (Internet upload/upstream as well as to other machines in the local (!) network) is very very slow. Below 0.1mbps.

Setup with very slow connection:

Laptop -> Cable -> RUTX10 -> Wifi Client -> FritzBox

However, this variant is fast as it should be:

Laptop -> Cable -> RUTX10 -> Cable (WAN Port on RUTX10) -> FritzBox

The WiFi signal strength is shown as >80% in the RutOS web GUI. I updated the Firmware just yesterday.

My usage scenario is that I need to connect a tiny cable-based network (one PC, several IP cameras) to WiFi. That WiFi is of the respective client's infrastructure. So it should work not only with the FritzBox, but with everything. I just got the FritzBox at home for testing, that is.

1 Answer

0 votes
by
Hi,

As I don't have any way to test the FritzBox, could you check if there are any additional configuration under the FritzBox that could be limiting the speeds?

Maybe try other devices as well?

EB.
by
When I connect my Laptop directly to the FritzBox via WLAN, I get full speed. However, the RUTX10 as a client does not get full upload speed. Also the download speed is a little lower, but I guess this is because the ACK packages on the upstream are going out too slow.
by
Could you try setting both devices to communicate only through 40Mhz bandwidth rather than 20Mhz?

EB.
by

OK I tried this now: Only one wireless connection is active, which is the 5GHz connection to the FritzBox. I set the RUTX10 to "Force 40MHz mode" on the 5G. I think this is what you mean? - Situation is the same, downstream full speed, upstream very below 0.1mbps, while the internet connection can  do above 10mbps upstream. Signal strength in the RUTX10 is shown above 80%.

The FritzBox doesn't allow channel bandwidth to be set. I tried a couple of channels instead of the auto setting (which had picked channel 40), no change of situation. Also, I live in a house that with not too much around it, there are now other 5GHz networks around.

I tried lowering the MTU on my Laptop, made things not better, rather worse. Tried lowering the MTU on the RUTX10's WWAN device… upstream speed test drops to 0.00mbps.

Also I logged into the CLI of the RUTX10 and ran "speedtest" – which wouldn't yield a better performance. The difference to running speed test on my Laptop is supposedly, that no routing in the RUTX10 happens, since it would just connect via its WWAN interface IP.

So there really is an issue with the WLAN in client mode in my RUTX10 or with the device in general, maybe a bug/misconfiguration that cannot be fixed using the GUI.

First job with supposedly that configuration comes closer… getting nervous.

EDIT/UPDATE: It works without any issues with other FritzBoxes, I visited relatives and friends today and tried. I'm busy the next days, but probably a firmware update of our FritzBox at home could fix this issue. So, the RUTX10 is alright, great little rugged box that works as designed.

by
Glad you got it working.

Thank you for your feedback and have a nice day!

EB.