FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12727 questions

15118 answers

24262 comments

47316 members

0 votes
2,779 views 2 comments
by
I'm using a t-mobile sim and can't seam to get 4g with the RUT950. it currently only connects to 3g WCDMA. But using the same sim in a phone I get 4g lte.

I have both antennas screwed in.

My current settings are

Connection type- QMI

Mode - NAT

APN - fast.t-mobile.com

MTU - 1500

Authentication method - None

Service Mode 4g (lte) only

Thanks
by
We’re you able to get this issue fixed,  I’m using mine for the first time and I am too having the same issue.  All settings for mine are the same as yours with the exception of my APN is broadband as I am using ATT.

3 Answers

0 votes
by
I managed to get it working by factory resetting the router a hand full of times and playing with all the settings. Not really sure what fixed it. But it seams to me making changes to the sim page after the initial setup don't do anything.
Best answer
0 votes
by
Hi,

What is the product code of your router ?
by
Product code RUT950JG1XXX

also forgot to mention i'm running the latest firmware
0 votes
by

Had (have) similar problem. Was using only 4G in Bulgaria with A1 (former Mtel operator) and at one moment Could not anymore work via 4G  - just 3G and 2G. Sim Card from the router in my phone is working fine on 4G.

Factory reset did not work for me

For me the bootloader was 2.00 and 

Firmware version RUT9XX_R_00.02.818

Once I did upgrade first the Bootloader to 3.01 - it connected 4G in no time. Of course ..I moved to the latest Factory Firmware, but was impossible to me to make it work .Probably some setting I could not manage to put properly. Tried randomly with some of the firmware versions 4.xx and 3.xx - but did not connect to the 4G  - Status "disconnected"

The 2.xx FW are not available on the Teltonika Website :( it was hard to me to find the 2.xx FW to test and finally when I put this ver.RUT9XX_R_00.02.818 it worked immediately again. No idea what happened after that maybe going further with the Router configuration.. but it keep showing for the 4G status Disconnected.

any ideas are welcome