subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
733 views 7 comments
by anonymous

I've setup a TRB141 to publish the readings from the analog input over mqtt every 5 seconds.

  • after some hours, the publication of mqtt messages stopped.
  • I can still reach the router over the openVPN connection and can login using ssh
  • the http interface returns "Bad Gateway. The process did not produce any response"
  • I can still reach the router using modbus tcp  and query the data.
  • DNS no longer worked. From the command line, I was unable to "ping", however "ping" worked
  • I was unable to reboot the router using "reboot" on the command line. After I entered the command, the led's started flashing. After 2-3 minutes, I canceled the command and verified with "uptime" that it did indeed not reboot. The leds returned to their regular state.
  • After a power cycle, the router is working as expected
Firmware is TRB1_R_00.02.05.1

5 Answers

0 votes
by anonymous

you can reproduce this issue:

1) activate the modbus tcp slave

2) setup a modbus tcp master with period = 5

3) setup a sender with period = 5

==> initially, the mqtt-message is an array of 3 (as expected) and is delivered every 5 sec

==> after some hours, the webui can no longer be accessed and the mqtt messages contain only an array of 2 (DataRX and DataTX, the "analog in" value is no longer transmitted)

This might be due to modbusd consuming too much virtual memory...

0 votes
by anonymous
Found another way to reproduce this issue:

1) activate the modbus tcp slave (don't use modbus tcp master / data sender)

2) query the modbus tcp slave every 5 secs

in my case, it failed after 1h 20min. same behavior as before ("bad gateway" when opening the ui, high virtual memory for modbusd). hence, apparently, the modbus tcp slave is not implemented properly.
by anonymous
this also happens when you query the device every 15secs, it just takes longer...

however, found a way to recover the device. If you login with ssh and kill the modbusd process, you can then again use the webui...
0 votes
by anonymous
Hello, could you please try flashing this test firmware without keeping previous settings and let me know if functionality works as expected?
by anonymous
i have the same problem with my TRB140.
now i update to your test firmware - i will check.

4455     1 root     S    67344  42%   1% /usr/sbin/modbusd
same Problem again
by anonymous


Please flash attached test firmware regarding fixes for Modbus and provide feedback whteher it works correctly
by anonymous

to test, i send every 1,5 second a request.
it fill up the space until 42% and crash.

by anonymous
Hello, sorry for a late reply, but RnD tracked down a memory leak and fixed it. I am attaching a test firmware, please test it once more and let me know if you are still experiencing the issue.

by anonymous

icrease very slow

by anonymous
The URL does not work.
0 votes
by anonymous

modbusd    42%

0 votes
by anonymous
I´m experiencing the same issue on the same firmware TRB1_R_00.02.05.1 with my TRB141.Was any solution to this discovered?