FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
298 views 2 comments
by anonymous
Since upgrading to firmware 2.05.1, the RUTX11 response to a 'status' SMS has shown an incorrect Mobile IP address, but a correct WAN IP. The RUTX11 is set up for failover between the WAN and mobSIM1. Without a WAN plugged into the router (so its using the SIM), the 'status' response shows a correct WAN IP 49.224.xxx.xxx and an incorrect Mobile IP 100.90.xxx.xxx. If the WAN cable is plugged in (so the routers using the fibre supplied WAN), the 'status' response shows a correct WAN IP 10.20.20.10 and an incorrect Mobile IP 100.90.xxx.xxx.

1 Answer

0 votes
by anonymous

Hello,

If I understand correctly, in both cases you are getting the wrong mobile IP? I just tried to replicate the issue myself and in both cases got the correct status message. Maybe you are getting dynamic Mobile IP and the router status is still reporting the old one? For testing I used this status configuration: 

Regards.

by anonymous
The problem is that the Status response is showing an incorrect IP address in the Mobile IP field (%mi) of 100.xx.xx.xx, but the correct IP address in the WAN IP field (%wi) of 49.xxx.xx.xx if the SIM is providing the WAN connection.

I noticed that some other RUTX11's were showing the correct Mobile IP address in the status message. The modems with the correct response were using modem firmware EG06ELAR03A05M4G, while the modems with the incorrect response to the status message are using the newer modem firmware EG06ELAR04A03M4G. I upgraded the modem firmware of an RUTX11 that was giving the correct response to the status SMS, and immediately after the modem firmware upgrade the status response started showing the incorrect Mobile IP address.

Is there a way to downgrade the modem firmware, or can this issue be fixed in the next device firmware release?

UPDATE...I just found an X11 with the older modem firmware that is also showing the wrong Mobile IP address in the status message... That doesnt explain why the previous X11 started showing the incorrect Mobile IP after I upgraded the firmware though...more thought required....
by anonymous
Hello,

Please send me your troubleshoot file via private message or attach screenshots from your status page and screenshot of SMS you are getting.

Regards.