8844 questions

10494 answers

16453 comments

15781 members

0 votes
159 views 0 comments
by

I have purchased more than 10 Qty. TRB 145 GSM Modem. However, I am unable to send text SMS through this Modem. I tried though Hyper Terminal and our software application but I couldn't get success.

Steps I have followed:

1. Login into the web application and first downgrade firmware to get the option of RS232.

2. I have changed the control option - System > RS485 > Modem (and Save)



After selecting COM 1, continuous error or auto printing is coming and I unable to type any AT commands. But anyway I want to send SMS through my application or through GSM modem.

It should not like every time I will have to save or change settings in the web portal.

1 Answer

0 votes
by

Hello,

Download TRB1XX device patched firmware version. It includes several fixes for RS interface full control modem mode. Download link:

https://kaunas.teltonika.lt:444/f/bc13486d443c4018a12b/

Enable RS interface for Modem type, Full control mode.

Use ATE command to enable echo - ATE1

Stop QCSQ status messages - AT+QCSQ=0

Use these AT commands to send SMS (https://wiki.teltonika-networks.com/view/SMS_sending_command ):

AT+CMGF=1

AT+CMGS="+3706...."

Regards.