4781 questions

5854 answers

9373 comments

5704 members

0 votes
190 views 7 comments
by

I have the rut 955, and i have an application that tells me the current ip address of the teltonika unit as it sends a packet to the server every one minute. I can now access the router to switch on and off my relay from my webpage using

 http://192.168.2.254/cgi-bin/output?username=user1&password=user1&action=off&pin=relay 

http://192.168.2.254/cgi-bin/output?username=user1&password=user1&action=on&pin=relay   , But when i put my public ip in there it does nothing. I have my HTTP enabled. And my firewall is not blocking anything. I even tried to change the HTTP port in the teltonika to see if it made a difference. Any help is appreciated. Thanks!

2 Answers

0 votes
by
Hi,

Are you sure that you have Public IP? Can you access it from an external network and enter your WebUI?

EB.
by
No i can't reach it. I am 100 percent sure that I have the right ip address, as that application have been used for other projects. But when i look inside the WAN of the router I only see a private ip. But when it sends packets to me I can see its public ip on my PC. SO i think its a shared ip address. Then whats the way i can connect to the router?

Thanks a lot!!
by

As I saw your comment on another answer I believe you have not set up an APN. Please make sure you got Custom APN given by your operator and write it down in Network > Mobile. Without any other configuration, you should be able to get at least Public IP.

EB.

by
Yes i have a custom apn, and the router is connecting to my server. I don't know why the ISP is not giving me a public ip.
by
Hi,

Please contact your ISP. Maybe they didn't give you the right APN or you shouldn't be getting it.

EB.
by
Hey, now when i changed the sim, i am getting a public ip address. But still the request is not going through
by
Hi,

Would you be willing to do a remote session via AnyDesk? Please private message me and let's organize a date.

EB.
0 votes
by
Check that you are trying to access with the correct protocol in the browser address bar (HTTP or HTTPS).

Do not activate the predefined "passthrough" rules in Firewall -> Port Forwarding as what they actually do is redirect to 127.0.0.1 which may or may not work if you have several LAN addresses (VLANs).

Check if you have enabled System -> Administration -> Access Control -> Remote management options.

Best option to access router from WAN is to make a redirection from a certain wan port to port 443 on lan:

"TCP - From any host in wan - To any router IP at port 8080 - Forward to any host, port 443 in lan"

And access that port from outside using HTTPS protocol. (Change port 8080 with whatever you like most). You won't need to enable Remote administration if you do this.

If you need to see if router is reachable, enable ping in Firewall -> Traffic Rules and try to ping router from outside.

You may need to reboot RUT to make some things work. It has driven me crazy sometimes because of this.
by
Thank you so much for your reply

So do you reckon that this connection is not reliable for projects? I was trying to trigger the relay using the HTTP web requests using a webpage. But even though i know the public ip from my packet, the WAN inside my router still shows a private ip. Is it because of that. Thankss!!!