4781 questions

5854 answers

9372 comments

5704 members

0 votes
88 views 4 comments
by

I could not switch off OpenVPN by using the SMS Utility. In the settings, I switched off authorisation and allowed all phone numbers to trigger. Latest firmware is installed!
I also tried to switch on/off GPS, and it works fine!

By the way, the "mouse_over" hint text is missleading:

Regards AG

1 Answer

0 votes
by

Hi,

Have you noticed the text under the fields? Did you do it exactly as it said?

To check your active interfaces you need to go to CLI and execute ifconfig and you will find your OpenVPN interface name.

Then test this SMS utility by sending "routerPassword vpnoff nameOfVPNinterfaceFromIfConfig"

e.g admin01 vpnoff tun_s_asd

SMS text, which let's you to stop or start OpenVPN instance. After secret word you have to write OpenVPN name. E.g. "vpnon client_name" or "vpnoff client_name"
by
Hi,

(1) No, I did not follow exactly as it said, and l kep the standard setting for State=OFF --> see commented screen shot above. Please confirm.

(2) I learned from your reply, that the interface name retuned by "ifconfig" must be used, instead of the TUNNEL NAME shown in the VPN configuration section. It would be very helpful, to add this hint in the RUTX11-wiki!

Unfortunately, I still was not able to switch OFF OpenVPN!
by
1. State in this scenario means the function itself, if the state is set to off - after sending SMS it will set OpenVPN interface state to OFF.

2. How are you testing this? Try pinging the other end of OpenVPN after sending vpnoff. It should not be pinging anymore.

EB.
by
I checked the relevant setting in the GUI to verify if VPN is switched off, and in addition, I tried to reach a remote clients GUI, which also was possible.

Switching ON/OFF GPS works fine, as I informed before.
by
I've tested it and it worked just fine. Could you reset your router to defaults without keeping the settings and try configuring your VPN again? Then try sending an SMS.

EB.