4450 questions

5470 answers

8579 comments

5378 members

0 votes
63 views 7 comments
ago by

I configured an OpenVPN server on Ubuntu and a OpenVPN client in Windows.

The connection is working fine.

Then I tried to configure a RUT950 as a OpenVPN client, by uploading the .ovpn files that the server automatically generates.

This is not working.

From the log I see the error
 
Linux ifconfig inet6 failed: external program exited with error status: 1

how can I solve this?

Thank you

2 Answers

0 votes
ago by
Hi,

The error indicates that on one of the ends IPv6 is used and you have to enable IPv6. For this case, I would suggest finding on what side does IPv6 appear and make sure it changes to IPv4 to avoid any more problems.

EB.
ago by

I disabled ipv6 both on server OS and OpenVPN server, but the error is still there, and now, after logread I have another notification

client_client1 s in a crash loop 6 crashes, 2 seconds since last crash

so I think that I should disable ipv6 on Teltonika router, can this be done?

ago by

In RUT950 Network > Mobile > General put a tick on "Use IPv4 only".

ago by
Thank you for the tip, however that option is already checked
ago by
Could you share server and client configs of OpenVPN here?
ago by

Solved! It was a server problem.

In the file "server.conf" I deleted 2 lines:

server-ipv6 ecc..

and

push redirect-gateway ecc...

Thank you for the support

ago by
Glad you've sorted it out.

Have a nice day!

EB.
0 votes
ago by
I think "inet6" comes from lack of ipv6 support on the router.
Try to enable ipv6 setting under "System / Administration".
ago by
Yes, but in most cases, IPv6 isn't a default option that you would want to use if all other options may require or was pre-configured to work on IPv4.

EB.