FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
627 views 6 comments
by

Hello, I am using the latest firmware RUTX_R_00.02.05.1 and modem firmware EG06ELAR04A04M4G and purchased this device on the basis of a use case that the device should meet (sales blurb plus questions clarifying this use case were positive) but I cannot get it working as planned. The desired use case is:

RUTX09 provides WAN backup over an EE (UK) 4G service to a BiPAC VDSL router (router has three WAN ports available) and provides both the IPv4 and IPv6 EE “public” addresses to the BiPAC router for use under the main VDSL service failure but without an extra NAT layer.

The assumption is that the RUTX09 needs to work in bridge mode. However several bugs documented elsewhere:

(1)  RUTX09 DHCP assigning local addresses before mobile WAN comes up preventing public IP addresses being leased to the main router for 12 hours.

(2) No combined IPV6 & IPV4 address support from the 4g service provider under bridge mode, only IPv4 only or only IPv6, however both are provided fine when in NAT mode.

(3) No access to the internet for the RUTX09 when in bridge mode so firmware upgrades, speed tests cannot be performed.

(4) No obvious way to access the management pages once bridged.

....means that the product just does not meet the basic requirements for my use case, advice welcome!

NOTE: Bug (2) has been acknowledged by Teltonika, the rest are pending.

1 Answer

0 votes
by anonymous

Hello,

Here are my comments to your questions:

(1)  RUTX09 DHCP assigning local addresses before mobile WAN comes up preventing public IP addresses being leased to the main router for 12 hours.

When the RUTX09 gets WAN IP address it should assign a new IP to the connected device. Try using bridge mode with your computer and would see how it does that. Maybe your ADSL device does not accept it for some reason?

(2) No combined IPV6 & IPV4 address support from the 4g service provider under bridge mode, only IPv4 only or only IPv6, however both are provided fine when in NAT mode.

IPv6&IPv4 support is available in the latest FW. More information can be found here:

https://wiki.teltonika-networks.com/view/RUTX09_Interfaces#General_Setup:_Mobile

(3) No access to the internet for the RUTX09 when in bridge mode so firmware upgrades, speed tests cannot be performed.

This is how Bridge mode was designed to work. Try using Passthrough mode.

(4) No obvious way to access the management pages once bridged.

Try setting static LAN IP address on your device and you should be able to reach it.

Regards,
Justin

by
Hi Justin,

IPv6 and IPv4 is “supposed” to be supported in the latest firmware but it is not working in bridge mode, Jerome has tested this with me and gets the same results, if the mobile interface is set to IPv4 only then you get an IPv4 address from the mobile provider, ANY OTHER setting gets you only an IPv6 address, no IPv4. When in NAT mode this works ok. So it is a proven bug.
by
Hi Justin, I am confused with your comment of bridge mode vs passthrough mode. According to the manual bridge mode bridges the LTE IP address and traffic to the LAN. But passthrough mode bridges the WAN IP address to the LAN ( I assumed this meant the WAN port on the RUTX09 assuming this is connected to a WAN service). If so this is of no use to me as I do not have any other WAN service connected to the RUTX09 (LTE only). My assumptions seem to be correct as when I test passthrough mode I do not get the LTE IP address on the lan port. Please confirm.
by anonymous

Bridge mode would assign ISP IP to your end device (if you set private IP on end device, internet connectivity won't work), passthrough would do the same, but it also works when you get/set private IP on your end device (it would be doing NAT then).

"(1)  RUTX09 DHCP assigning local addresses before mobile WAN comes up preventing public IP addresses being leased to the main router for 12 hours."

This hopefully would be solved in next firmware update as it's a bug, in bridge mode, dhcp should be disabled, if you disable it manually, you won't get ISP IP.

Workaround in bridge mode for this is:

Network - Interfaces - LAN

IP static 192.168.1.1 

Enable DHCP - yes

Start 1

Limit 1

192.168.1.1
192.168.1.1

Your end device won't get private IP from DHCP as it's already taken by your rutx09 and would wait until modem is connected and your end device receives IP from ISP.

by anonymous

Hello,

If Jerome has managed to replicate the issue, I am sure he will inform RND team about this and they will fix it.

Bridge - bridges the LTE data connection with a device in LAN. In this mode the router relays the IP address received from the ISP to another LAN device (e.g., computer). Using Bridge mode will disable most of the router’s capabilities including DHCP and you will only be able to access the WebUI with a static IP configuration.
Passthrough - bridges the LTE data connection with a device in LAN. While in Passthrough mode the router will maintain an Internet connection and be accessible from LAN (DHCP Server is not disabled).

You misunderstood the way it works.

I have tried to replicate the issue of DHCP assigning LAN IP when using bridge mode, but everything worked just fine. Could you provide me steps on how to reproduce it?

Regards,
Justin

by anonymous

Hi, I didn't misunderstand anything, one thing is what it should do and another what it actually does - what I wrote are my experiences with rutx09. I have it connected to linksys wrt1900acs running openwrt.

Bridge mode - when received private IP (modem is not connected yet), it will not change private IP on wrt1900acs until dhcp lease expires and internet connection does not work - this is a bug and dhcp should not be enabled at all in bridge mode, when I manually turn off dhcp server in bridge mode, I won't get IP from ISP. Also, when I receive ISP IP on my wrt1900acs, I can still connect to rutx09.

Passthrough mode - when received private IP (modem is not connected yet), it will not change private IP on wrt1900acs until dhcp lease expires and internet connection works, because it does NAT.

Also, every time, I change bridge/passthrough/NAT mode, I need to restart rutx09, because it behaves strangely (I can't remember exactly, when I was testing it, something like it worked with private IP in bridge mode when I changed from NAT etc..)

"I have tried to replicate the issue of DHCP assigning LAN IP when using bridge mode, but everything worked just fine. Could you provide me steps on how to reproduce it? " - in my case, what is enough to have set IP to dhcp on wan port on wrt1900acs, restart rutx09, immediatelly restart wan interface on wrt1900acs and once rutx09 is up, it will assign private IP to wrt1900acs wan port (modem is not yet connected). I sent troubleshoot file to VidasKac, if you need it, ask me or him to send it to you.

by anonymous
Hello,

If Vidas is already informed about this, I am sure, that he will help you.

Regards,
Justin