7951 questions

9404 answers

15104 comments

12979 members

0 votes
553 views 4 comments
by
Good morning,

I am looking at the RUTX12 with 2 active Sims and want to understand the how to achieve the following

1) two pools of devices (both with DHCP addresses)

2) all devices can see each other on the LAN and communicate

3) pool 1 devices access the internet via Sim 1

4) pool 2 devices access the internet via Sim 2

5) all devices (pool 1 and 2) use the ethernet WAN as a failover if the relevant Sim loses connectivity

Is there a clear set of instructions that explains this type of setup?

I am due to configure this device this week!

regards,

Dan

1 Answer

0 votes
by

Hi,

1. First of all, we will need a VLAN - go to VLAN and create a new VLAN by ID: 3 and don't assign any of the ports for it yet, leave them all OFF.

2.To create two pools we will need another LAN interface. Go and create one with 192.168.2.1 IP.

It won't save you, as it needs a physical device, you can find it in Advanced Settings, and once you find where to set it, select eth0.3 (VLAN by ID 3).

3.Now as we have a working separated DHCP server - go to Network > Routing > Advanced static routes and create table by ID: 100

Add static IPV4 route, which would lead to the first modem, configure it the same way as in the screenshot.

4. Create another table with ID: 200 and the second modem selected in Static IPV4 routes (other fields are the same).

5. Create one more table with ID: 300 and interface selected as WAN.

This time you will have to change one field - IPV4-Gateway, instead of 192.168.3.1 use your own Wired WAN gateway.

6. Go back to Advanced static routes and scroll down to Routing Rules for IPV4.

Here we will need 4 rules.

First rule:

Priority: 1

Incoming interface: first LAN

Lookup table: 100

Everything else must be set as default.

Second rule:

Priority: 1

Incoming interface: second LAN

Lookup table: 200

Everything else must be set as default.

Third rule:

Priority: 4

Incoming interface: first LAN

Lookup table: 300

Everything else must be set as default.

Fourth rule:

Priority: 4

Incoming interface: second LAN

Lookup table: 300

Everything else must be set as default.

7. Now go to your VLAN settings again and set Untagged on any LAN port you want next to VLAN ID: 3 (remove untagged on a port next to VLAN ID: 1 accordingly).

And it should be done here. If you connect your cable to the VLAN ID: 3 port and if your Network Adapter DHCP settings on your computer are set to automatic - you should get IP from the second LAN and it will use your second modem traffic. Once you remove the SIM card from the second modem - it will lead you through the lower priority IPV4 rule and will now use Wired WAN traffic.

If you wish to use WiFi - just simply select your wanted LAN in the wireless settings of your access point.

EB.

EB.

by
Thank you that is a fantastic answer.

One follow on question,

The wifi in this property is provisioned through a mesh of AP's that connect back to a mesh root AP.  It is this mesh root AP that is connected to the teltonika device.

On that basis the majority of the devices on the network will connect to the teltonika router via a single lan port,

does your solution still work?

regards,

Dan
by
As long as access point users come back to the router and use the DHCP server that is set - yes, it will work without a problem.

EB.
by
I have a similar problem. I am using load balancing, but I want to use just one modem for the connection of special device that accesses a certain server on the internet, which does not accept load balancing.

So I tried out the suggestion of EB and created a VLAN which is connected to my special device, a routing table with a static route according to his advice and then a routing rule. After saving it, the route with the new routing table is listed in the STATUS/ROUTES screen and works fine with my device on the VLAN.

But after reboot the route with the new routing table is vanished from the STATIC/ROUTES screen and the connection of my device behaves again according to the load balancing setting, which means, the server on the internet gets only half of the data, although the routing table and the routing rule are still visible in the NETWORK/ROUTE/ADVANCED STATIC ROUTES screen.

How can I avoid this? Do you have any idea?

regards

Sabine
by

Hi folks,

in the meantime I figured out, that the setup of the decribed configuration is dependend on the firmware version. It has worked as decribed above with firmware version 

RUTX_R_00.02.05.2. Using an earlier firmware version I could not setup the routing tables.

regards
Sabine