8298 questions

9759 answers

15541 comments

13863 members

0 votes
158 views 1 comments
by
Hi,

I use TRB145, I collect data from Modbus RTU with Modbus Serial Master. It works great, however I still have a problem what block me to use the sensor for its purpose:

In the json file there is no mention of the data source. If I have more sensors on the same network, I can't make a difference between them. Of course I need to use the unit with many sensors together.

{"TS": "1604406937", "D": "03/11/2020 12:35:37", "data": 13700,13700,13700,13700,237,13700,13700}

This is what I have. Time stamp, datetime and the data. No reference for the data source.What I'd need is the device name from the settings or at least the slave ID number...

Do you have any ideas how to fix it?

Thanks!

2 Answers

0 votes
by

Hi,

Please make sure you're on the latest firmware version.

Right now I checked and there are options in JSON formatting that let you include these values:

Modbus slave ID %i

Modbus slave IP %p
Are you able to see these in your Data to Server configuration page?
by
Yes, that was the problem! Thanks for the prompt support!
0 votes
by
I have a bit the same issue, but the solution with slave ID will not help for me, cause my Modbus client (PLC) has several sensors (analog inputs) connected. So any chance to seperate the register values in parameter %a ?
Or is the only chance to seperate the values on the side of the MQTT subscriber ?