subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
326 views 2 comments
by anonymous
I work for a company that makes IoT devices. If one of our Ethernet IoT devices is connected to the RUT955, the router stops responding to the IoT device after about 10 minutes of no Ethernet packet activity. The IoT device sends sensor readings every 15 minutes to the cloud, it also obtains an SNTP update every 10 minutes. When the RUT955 stops responding it ignores the DNS lookup for the SNTP update, and when the readings are to be sent it also ignores that DNS lookup. It starts working again if there is a DHCP update.

I have been able to keep the system running by programming the RUT955 to send a ping to the IoT device every minute (the RUT955 ignores the response). I have also been able to keep it running by programming the RUT955 WAN Ethernet port to LAN and connecting the IoT device to this port. Due to the nature of our customers application and the volume of devices being sold, we need to do all we can to insure problem free operation.

The IoT device uses the LAN8740AI Ethernet PHY chip from SMSC. We have 2 other Ethernet products that use the ENC424J600 Ethernet PHY chip from Microchip, both work without issues.

Any help would be appreciated.

1 Answer

0 votes
by anonymous


Regarding the issue you are having as what I understand you internet connectivity is cut or disconnected after 10 mins.

Most cases this is happening because the IoT device maybe configured with a wrong Default Gateway or missing this default gateway configuration. Also have you tried using DHCP Option:  6, DNS Server IP, DNS Server IP (2) e.g 6,, 

May i also know what is the signal quality you are receiving from the sim card? Have you tried running ping on CLI and check if after 10mins the ping will be stopped?? If you are still having the same problem after testing the said scenario's kindly send me a copy of your troubleshoot file.

Note: In getting the troubleshoot file the router needs to be on for 10mins the time the router will loss net connectivity. Don't reboot or shutdown the device if you haven't downloaded the troubleshoot file. 

Hope it helps



by anonymous
Thank you for your response Jerome,

I need to supply more information. The RUT955 is connected to the internet using WiFi, it is not using the cell modem. Our customer first discovered this problem when using the cell modem but later found that the problem also happened with WiFi. After the power is first applied to the IoT device, or after a DHCP update, the system works as expected. The IoT is able to connect to the cloud using TCP and transfer information, and SNTP also works. By using an Ethernet network tap to avoid placing any additional network traffic on the connection between the IoT device and RUT955 I was able to obtain a Wireshark capture showing the issue.

I enabled remote access control so I could access the RUT955 from WiFi (in order to not introduce another Ethernet device). When the 10 minute issue happened I ran ping on CLI and it worked as expected. I have the troubleshoot file but do not know how to send it.
by anonymous

Could you try this scenario:

1. Connect a laptop instead of the said IoT device to the RUT955.
2. Check if the internet is always up for like 10mins
3. If there are no issues encountered for this one meaning the issue is on the IoT device config maybe.

You can send me the troubleshoot file via PM.

I am not able to have any issues with the RUT955 on my side with the use of WiFi as Main WAN and connecting my phone and office laptop on the same RUT955 it is working flawlessly.