FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
1,814 views 6 comments
by

Hello everyone,

TL;DR: I'm in the process of investigating a situation where the 500MB data allowance for my SIM used in a Teltonika RUT955 was exceeded and I'm facing some challenges, I would much appreciate some assistance.

The setup:
The modem is connecting a system in a remote location, which means I don't have direct access.The system it is connecting to the internet is using very little data, a couple megabytes per week. The modem is connected to the internet, and I can SSH into the modem from my device, which I'm accessing via a reverse SSH tunnel. This is the only way I can access and configure the system (currently).

Issue #1:
During the prototyping of this system, I registered an RMS account and registered the device, and for the trial period, everything was working fine. Since remote monitoring wasn't a necessity, I did not purchase a license, assuming that should I need this feature, I can go for it and re-gain access to the system remotely. When we faced issue#2, I tried logging in to the RMS account immediately, but I couldn't do so. First I was facing a "Bad login" error message, that later changed to "Bad credentials". After many password reset attempts, I was still unable to log in until a few days ago, when it finally worked. Then I purchased a license, and switched on monitoring for the device, but it is still shown as disconnected.
I logged in via SSH on the router, and according to the information I managed to gather online and from the router, the RMS connection is enabled and should be working, see pastebin link further below.

I rebooted the modem, but it still doesn't show up on the portal. Looking at related forum posts suggesting to reset the modem to default settings, since I don't have direct access, this is not an option to me. I don't want to fiddle around too much on this system, because it is mission-critical, I cannot cause any downtime, unless it is absolutely necessary.

Is there a way to force the system to connect to the RMS portal without having to reset it?

Issue #2
The system has barely consumed any data over the course of the last ~3 months before Christmas, but suddenly on the 30th of December, the 500MB Data allowance of the system completely ran out. It was only on the 3rd of January when I managed to top up and get the system re-connected.
I am certain that:
- Nobody had access to the system, or connect a device to it and use it's data allowance
- None of the connected systems are able to generate such high traffic, even if I would try to force them to do so.
Here is a link to a pastebin of the output from uptime, ifconfig and the RMS configuration.
The way I interpret the output of ifconfig is that the devices on the LAN have nowhere near generated as much traffic as what was going through wwan0. Assuming that the connected system's data consumption was the same over the course of the last 3 months, it seems that the 500MB traffic was a one-off situation, otherwise we would see much higher values on wwan0 for the 78 day period.
Since the top-up on the 3rd, the SIM card's management dashboard is showing 0MB of data used, which is probably due to the general traffic being so low, that it is not even counted by the operator. I have never checked the dashboard before, and there is no history available unfortunately, but almost two weeks without measurable traffic makes me believe that a one-off event occurred and it was caused by a device outside of my control, and the only one in the system is the RUT955 modem itself.

Any other suggestions/explanations what could have caused such high traffic, and how this could be prevented in the future?

Thank you for reading and thank you forward for any responses!

Cheers

1 Answer

0 votes
by anonymous
Hello, Matesh,

I've never heard about such a consumption by RMS system and this is not really technically possible.

Could you try to set a data limit for 5MB for example and enable TCP dump ? https://wiki.teltonika.lt/view/RUT950_Administration#Troubleshoot

Just be sure to disable it afterwards. By looking into a TCP dump file it might be possible to see the source of consumption.

For now I can only see that RMS interface is not up and it could not consume data.
by
Hello Vilmantas1,

Thank you for your response. Indeed, the RMS interface is down, and as I mentioned, and I can't get it to reconnect. Which also makes it difficult to perform the suggested troubleshooting method without being able to access the modem directly. I'm not sure about the data limit either, I can't allow the system to be disconnected for long time, and since I don't have direct access, recovering it if something goes wrong would be a huge pain in the back side.

It would be great to know why the RMS doesn't reconnect. Is there a way to get the status of the RMS connection or a log file why it is not connecting? It was working when the system was deployed and no parameters have been changed since.
by anonymous
RMS was recently updated which might have caused your disconnection.

Are you sure that router has internet connection now ?
by
Yes, I can reverse SSH into my system and also SSH into the modem from that system.
by anonymous
Hello,

Would it be possible to get SSH access for Teltonika engineer ? If yes I'll contact you in PM.
by
Hello Vlilmantas1,

Due to the nature of the system, the only way I can arrange that is via TeamViewer. If that is satisfactory, get in touch!
by anonymous
Hi again,

It would be great to arrange remote for Monday. For some reason I can't PM you. Can you send a message to me ?