FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
2,203 views 6 comments
by anonymous
I have a device with a fixed IP 192.168.128.3 and a web interface on ports 80 and 443. I want to access this interface remotely. The IP of the device CANNOT be changed. The SIM card I use has not static IP but it is "open" meaning that it is public. I send an SMS to RUT240 and I know its IP. If I enable remote HTTP/HTTPS access I can access the router's web interface by using the public IP. I also changed port from 80/443 to 8080/8081 and also works. Now, trying to access my device web interface: I changed router's IP to 192.168.128.1 in order to be on the same network as my device and I set port forwarding from external 8080/8081 to LAN (192.168.128.3) 80/443. If I perform a PING from the router (192.168.128.1) to my device (192.168.128.3) it replies correctly. But accessing it from the internet doesn't work. I also tried external 80/443 to LAN 80/443 and also doesn't work.

My question: How to configure the router in order to access the web interface of my device on IP 192.168.128.3 and LAN ports 80/443? Note: I also updated the router's firmware to the latest version.
by
You're positive 80 and 443 are open on 192.168.128.3?

Also, make sure  NAT-P is enabled.

john

3 Answers

0 votes
by anonymous

Hi

As I understand it, you changed the ports for accessing the router's web interface to 8080/8081. Try to specify any other external port instead of 8080/8081 in the forwarding rule.

Example:

Regards.

0 votes
by anonymous
Yes ports 80 and 443 are open on 192.168.128.3. If I plug the LAN cable to the device's ethernet port and to pc I can access my device's web interface. I don't know what "NAT-P" is. Where I enable it in Teltonika RUT240? However "NAT loopback" is enabled in port forwarding rule.
by anonymous

Hi.

Have you tried what is described above? I just tested the forwarding on my rut240 with the latest firmware, everything is working fine.

Regards.

0 votes
by anonymous

I have tested again and again many things, I tested port 7000 and doesn't solve the problem. It is not a matter of port number. As far as I understand the problem is that my device controls the network, not the router. It has fixed IP (192.168.128.3) and the LAN port is for PC connection. The router should act as a wireless access point. If I use a wifi access point from TP-link and plug it in my device's LAN port it works fine. How  can I do the same with RUT 240 and be able to access the device from the internet? See attached picture.

by anonymous
BTW I installed more than 100 RUT240 routers in 2020 in same devices, but for different use, and I will installed more than 100 in 2021. I want 1 special setup for 1 special case and I see that the router cannot do it.
by anonymous

Have you configured the default gateway on your device? It must have your RUT240 address (192.168.128.1). Make sure your device isn't blocking http/https traffic.

by anonymous
I know. If I was allowed to do it and I would have solved the problem. As I said the device's network settings cannot be modified. The gateway is the device's IP (192.168.128.3). Is there a way to access that interface with RUT240? With TP-Link TL-MR3020 in Access Point mode I can access the interface via WiFi. I want to do the same with RUT240 via internet. What I think now is to combine these 2 products somehow...
by anonymous
Wi-Fi is a local network, unfortunately, without setting up a default gateway, you won't be able to access your device over the Internet. Apparently, your device only supports configuration from the local network.

Regards.