FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12691 questions

15070 answers

24150 comments

47148 members

0 votes
206 views 0 comments
by
Hi All:

Was going through the SDK instructions and came across this:

sudo apt-get update

sudo apt-get install -y build-essential curl devscripts gawk gcc-multilib gengetopt gettext git groff file flex libncurses5-dev libssl-dev python2.7 subversion unzip vim-common zlib1g-dev wget

Python 2.7 is obsolete. I run Gentoo and it was pulled our of portage in January. I finally "cleansed" my machine of all python 2.7 remnants but its required for the SDK? Really? Python 3.7 won't work?

Can someone confirm this?

Cheers,

John

1 Answer

0 votes
by
Hi,

These are minimally required packages so you would be able to compile SDK and firmware out of it. Higher versions should work as long as they have the same functionality and meet the requirements.

The only issue that could appear is that having Ubuntu 16.04 might be a requirement, but first I would suggest trying it on your own current OS before switching.

EB.