7572 questions

9026 answers

14571 comments

11782 members

0 votes
162 views 1 comments
by

Hello,

I have encountered a weird issue w/ WAN failover on the RUT955 (RUT9XX_R_00.06.07).

Important note, it is in a remote location so I cannot check it physically right now. Everything has been done cable-wise, what is left now is configuration.

I am currently using Mobile network as primary access to the Internet but want to set wired access and then switch them up.

While I enabled failover and configured wired settings, in Status->Network->WAN tab the WAN interface show itself as basically undetected:

but can be seen in "Topology" tab:

(I removed IP and MAC addresses)

I checked CLI and it also states that eth1 is down (as far as I can tell from documentation and community questions it should be this one).

My first thought was a broken cable so I grabbed another RUT955 I have (also ver. RUT9XX_R_00.06.07), and then tried to simulate the same scenario as above, ignoring obviously wrong network config and focusing on cable state (plugged / unplugged behavior).

But in Status->Network->WAN tab the WAN interface was either detected as plugged in (WAN port did lighten up) or appeared as crossed - with red "x" (when Eth cable was unplugged form RUT or the other end device). It never stays "untouched" as in example above. So I am not too sure about the cable now.

At this point I dont know what exactly went wrong, I am currently stuck and try to figure out some clues, hence this thread.

Can anybody help or suggest anything?

Thank you in advance.

1 Answer

0 votes
by
Hi,

I believe you're not too far from default configurations - so I would suggest restoring your device to default factory settings.

Once you do that do not be quick to connect WAN. Make sure the other device that is giving you that WAN connection doesn't have the same IP address or isn't running the same DHCP server in the same subnet. Once you're clear on that - go ahead and connect the cable to WAN and see if you get an IP address on Network > WAN page next to WAN interface. No configurations needed to make it work, so try not to configure anything without knowing it's really necessary.

Also, you stated that you tried another RUT9XX and it acted the same. It makes me wonder if it could be the other device on the other end of the cable. Please try using another router or another switch if that's possible and only then try connecting it to RUT9.

EB.
by
Hello again,

Cable was faulty and has been replaced.

But, something strange happened.

Interface went up, I could see in CLI arps coming form the site GW but in WebGUI arp table was empty (GW address had just zeros assigned). So, obviously no L3 traffic could reach it (GW).

After some experiments I found out that setting the site DNS server as health monitor target let the wired WAN stay as "ready" in WebGUI. It did not change anything but it was unexpected.

Restoring default configuration did a trick but I honestly done the same changes as before, and now it just works...

I suppose either there is a problem while switching between default WAN connections or after some time a few changes to config become cumbersome and software gives up when some cable work is done.

So, I think setting up Mobile WAN access, configuring wired WAN as secondary option, and then switching wired to primary choice should be avoided for now.

Thanks for your help, I really appreciate it :)

AR