8851 questions

10510 answers

16478 comments

15812 members

0 votes
109 views 0 comments
by

Model : RUT850 101180

Batch : C002

HW : 050S

Serial  : 

Issue :  Firmware upgrade from :  RUT850_R_00.01.03.4_WEBUI.bin  to   RUT850_R_00.01.04_WEBUI.bin

        

Resultant issues

1) can not downgrade back to RUT850_R_00.01.03.4_WEBUI.bin

2) Loss of communication with LTE/4G modem inside

Required actions : Method to restore the RUT850 to working order

Faults reports

1)  Webpage panel for Modem crashes

Web page url : http://192.168.1.1/cgi-bin/luci/;stok=99a26e69c627ba188855ee2f74fcbb5a/admin/network/mobile

/usr/lib/lua/luci/dispatcher.lua:525: Failed to execute function dispatcher target for entry '/admin/network/mobile'.

The called action terminated with an exception:

/usr/lib/lua/luci/dispatcher.lua:525: Failed to execute cbi dispatcher target for entry '/admin/network/mobile/general'.

The called action terminated with an exception:

...b/lua/luci/model/cbi/admin_network/ifaces_mobile.lua:11: attempt to concatenate a nil value

stack traceback:

[C]: in function 'assert'

/usr/lib/lua/luci/dispatcher.lua:525: in function 'dispatch'

/usr/lib/lua/luci/dispatcher.lua:270: in function </usr/lib/lua/luci/dispatcher.lua:269> 

2) when logged in via cli no comms possible with modem 

> > root@Teltonika-RUT850:~# /etc/init.d/modem stop

> > modem: stopping generic 3G modem...

> > modem: dirty modem reset or shutdown

> > Command failed: Not found

> > modem: removing USB driver

> > modem: done

> > root@Teltonika-RUT850:~# /etc/init.d/modem start

> > modem: starting generic 3G modem

> > modem: inserting USB driver

> > root@Teltonika-RUT850:~# modem: stopping generic 3G modem...

> > modem: dirty modem reset or shutdown

> > Command failed: Not found

> > modem: removing USB driver

> > modem: done

> > modem: starting generic 3G modem

> > modem: inserting USB driver

> > modem: stopping generic 3G modem...

> > modem: dirty modem reset or shutdown

> > Command failed: Not found

> > modem: removing USB driver

> > modem: done

> > modem: starting generic 3G modem

> > modem: inserting USB driver

> > modem: stopping generic 3G modem...

> > modem: dirty modem reset or shutdown

> > Command failed: Not found

> > modem: removing USB driver

> > modem: done

> > modem: starting generic 3G modem

> > modem: inserting USB driver

> > sh: you need to specify whom to kill

> > client_loop: send disconnect: Broken pipe

1 Answer

0 votes
by

Working Fix :  ST8 Firmware was upgrade after the RUT850_R_00.01.04_WEBUI.bin was upgraded and this fixed the issue.

Case solved and closed

Best answer