5652 questions

6863 answers

11066 comments

6944 members

0 votes
33 views 0 comments
by
Good Afternoon,

In earlier versions of the TRB142 the serial Bidirect mode worked but in the latest version of the OS 2.05.1 it no longer works.

The application we have has a device on the serial port (115200, 8, none ,1) that communicated back to a central server (10.0.0.1).  

In server mode with TCP port 15000 we can connect to the device from our server and the communications works.  

In client mode with the setting 10.0.0.1:15000 our device can connect to the server and the communications work but the connection is closed (I suspect from the server end).  Once the connection is closed the server can not reconnect to the field device.

The issues arise as the Instrumentation is run from solar panels/batteries and so we only turn the modem on at specific times or when the field device needs to upload data.  

In the previous OS the bidirect mode worked and allowed the connection to be initiated from either end.  Is there something in the new OS version that has changed this?  Is there anyway to downgrade from OS Version 2.05.1 to an earlier version?

Thanks in advance for any help you can provide.

Andrew

1 Answer

0 votes
by

Hello, 

Regarding your problem could you get a copy of a troubleshoot file and send it to me via pm. Also if you want to downgrade the firmware you can download the older firmware on this link for the  TRB142 device. 

TRB142 Firmware Downloads - Wiki Knowledge Base | Teltonika Networks (teltonika-networks.com)

You can downgrade it via going to System > Firmware > Upload file instead of server via file then just upgrade. 

Hope it helps

Regards,
Jerome