7607 questions

9040 answers

14582 comments

11885 members

0 votes
183 views 3 comments
by
We are evaluating the sim switch feature on the RUT955. It seems there is a problem with custom APN settings and sim switching. We are using Telia IoT sim cards in SIM1 with a custom APN set to internet.telia.iot. As a backup we are using 1NCE sim cards in SIM2 with custom apn set to iot.1nce.net.

Switching from SIM1 to SIM2 is working as expected but when switching back from SIM2 to SIM1 we get registration denied and the units reverts back to SIM2. Only way to get back from SIM2 to SIM1 is by power cycling the unit. Locking at the logfiles is seems as if the custom APN settings are not updated after sim switch and before attempting to connect to network.

How can this be solved?
by

Doing more investigations on this we can see a timing difference. It seems as if there is not enough waiting time when trying to switch back from SIM2 to SIM1. Is it possible to configure this timeout somehow?

Mon Dec 14 20:30:35 2020 local1.info gsmd[3457]: gsmd send: 'AT+CFUN=1' (10)

Mon Dec 14 20:30:49 2020 user.info Messaged[16409]: Start from new event "SIM switch" "Switched from SIM 2 to SIM 1 due timeout."
by

Based on more experiments we do conclude that it is, in a way, possible to configure this using settings for SIM Switching. It seems as if SIM Management - SIM Switching - Check interval is used to determine if connection is "good" when switching back. But the setting is used without retry attempts.

The inital setting (30 secs) is too short for the Telia card to get a connection. Changing this to 120 secs was a workaround.

Right now we go with:

  • Enable automatic switching
  • Check interval 120 
  • SIM1 to SIM2: On data connection fail, method ICMP echo, ICMP host 8.8.8.8, timeout =3 Attempts before SIM failover = 3
  • SIM2 to SIM1: Initial timeout = 5, subsequent timeout = 5
by

This was really helpful. Even with no SIM in slot 1 I could not get it to switch over to slot 2 until I increased the timeout on sim 2.

1 Answer

0 votes
by

Hello!

As stated earlier, use initial and subsequent timeout to increase the connection timeout.

BR

Aliaksandr