7591 questions

9029 answers

14584 comments

11836 members

+1 vote
97 views 0 comments
by

Hello

Right now i have some issues with the RUT955 Router. I want do Enable/Disable the Mobile Data Connection over the Modbus TCP Command: Switch mobile data connection (ON/OFF) Address: 204

If i send the Command to enable the connection, the Mobile Data Connection disconnects and stays Disconnected.

The System Event Log shows:                             Modbusd         Mobile connection has been turned ON

But in the Network Events the System shows:     Mobile Data     Mobile Data disconnected

The Router disconnects the Mobila Data Connection an i can only restart it after i reboot the System.

Actual Firmware on Router: RUT9XX_R_00.06.07.3

Is there a solution to this behaviour?

2 Answers

0 votes
by
Hi,

Could I ask you if your Modbus TCP is set up locally or remotely? If it's remote then it's logical that once the mobile data connection is lost your Modbus TCP connection should be also unreachable. So I need more information on that.

Thank you.

EB.
0 votes
by
Hello

The Modbus TCP is connected by LAN Port. So this Connection is not affected by the GSM Connection.
When i disable the GSM Data Connection by the Command 204, the Data Connection Disables as it should.
But when i enable the GSM Data Connection again with Command 204, the Data Connection stays disconnected.
The Router Shows in the Event Logs that the Command was processed. But The GSM Data Connection is not enabling itself any more.
It seems that the Router is not Requesting a new IP Address from the ISP.
Only after Reboot the Data Connection is working again. So i think there must be an issue in the Firmware.

Kind regards