5654 questions

6864 answers

11066 comments

6945 members

0 votes
91 views 0 comments
by

Hello.

I'm trying to connect RS232 and RS485 devices to teltonika routers/gateways, but I'm experiencing problems and cannot get this work, or not peoperly (at least RS232).

When I say rs232 and RS485, I mean I would like to connect I device on each port. But at this time I'm trying with onky one.

I've TRB142, TRB145 and RUT955

What works:
I'm able to connect a RS232 device to the RUT955, but through RS485!
If I connect to RS232, the connection is etablished, but no data is pushed over IP.
Do you have an idea why?

If I connect my device to the computer with a RS232 to USB adapter, I'm getting data. As I said, if I connect to the RS485 connector it works also.
So I would say that the connexion settings should be ok, the connected device should be OK too (is sending data properly).
Is some special configuration for RSR232 needed? Or a Firewall/trafic or other rule for over-ip function?

Second case: I tried to use a TRB142 without success with RS232 connection, as with RUT955. Again, with RS232-to-USB it works, using the same cable between. So it should not come from that. I would think that I'm doing something wrong somewhere, same on both RUT and TRB.

Third case: I tried to use a TRB145 without success with RS485 connection. The settings are the same as on the RUT955, the connected device is the same, the way I connected (cable/pins) also the same !
The WAN seems to be ok ("connected")
So I really don't understand where the problem can be, except if the TRB works differently than the RUT955 or some settings/rule should be added manually somewhere.

An idea, an advice?

Best regards and thanks for any help

1 Answer

0 votes
by