FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
419 views 5 comments
by anonymous

Hi I have tried to send or receive sms' from my RUT955 using a Verizon sim and it keeps timing out. The storage is showing 0 available and 0 used. Could this be a sim card incompatibility which is causing the "timeout"?

by anonymous

After spending about 5 hours with Verizon Tier 2 Technical Support over the last several days, we finally got the SIM card working. They don't provision your RUTXxx's IMEI correctly in your plan by default, even if you've given it to them multiple times. You can see this by logging into your MyVerizon account via the browser (not the mobile app), and checking your "Device ID". Over the phone, they insisted it was correct, but when I logged in, it was wrong. They had to escalate and get a Supervisor on the call to override the setting. 

That said, also by default all SMS is BLOCKED on data-only SIM cards. You have to specifically call them ask them to remove the SMS block on your SIM, in order to allow SMS to work, when provisioned against an IMEI that is a router. I had them do this today to my SIM, but I still can't send/receive SMS via the RUTX11. But popping that same SIM into a spare iPhone8, and I can send/receive SMS just fine.

The issue appears to be that there is no way to independently configure the SMS/MMS settings in the RUTX11's interface settings or mobile settings. I tried 11 different APNs, restarting the router between each change, and none of them allowed SMS to flow.

I can pop my T-Mobile SIM into either slot, and SMS works just fine with that carrier. Just not with Verizon's SIM card. Oddly, there's no way to tell the RUTX11 that SIM2 handles SMS, but SIM1 is the default, or even load-balanced between the two.

So I'm in a similar boat; Verizon SIM now works (minus displaying the "Cell ID", which my T-Mobile card shows), and no SMS. I'll keep hacking on this until I figure it out, and post back here with results.

1 Answer

0 votes
by anonymous
Hello,

First of all, make sure you are using the latest firmware version for your RUT955: RUT9XX_R_00.06.07.4. Then confirm that you successfully connect to your SIM card operator and have internet access. Try to send/receive SMS messages using this SIM card while it is inserted in another device (for example mobile phone). Also, confirm with your operator that your SIM card data plan allows using SMS.

Best regards.
by anonymous
Hi, thanks for your advise but I have already done all of the above. I have updated to the latest firmware and even downgraded to 6.05.3 to see if it made any difference. My SIM works fine from a phone and can sms send/receive. The sim card allows sms yes correct.

Would you have any other recommendations?
by anonymous
It is hard to tell, I checked myself with the latest firmware version and 2 different SIM cards. Storage worked as expected for me.

You could try to reflash the firmware using the bootloader menu:https://wiki.teltonika-networks.com/view/RUT9xx_Bootloader_Upgrade

Also, do you have the ability to test your router with another SIM card by any chance?

Regards.
by anonymous
Hi, can I ask where to find the latest bootloader firmware download? I have looked everywhere on the Teltonika website and cannot locate it. My current version is 3.2.5.
by anonymous
Hi,

It was my mistake to provide you the wrong link. What I had in mind is to install firmware via bootloader (not bootloader itself): https://wiki.teltonika-networks.com/view/RUT9xx_Firmware_via_The_Bootloader_Menu

Regards.