10879 questions

12963 answers

20220 comments

26092 members

0 votes
226 views 2 comments
by
Hi,

I've just upgraded RUTX11 to RUTX_R_00.02.06 firmware and sudo do not work (which could be previously installed and working). When after successful installation I use sudo I get this error:

root@rutx11:~# sudo --version

Error relocating /usr/lib/sudo/libsudo_util.so.0: getentropy: symbol not found

Steps to reproduce:

root@rutx11:~# opkg update

root@rutx11:~# opkg install sudo

root@rutx11:~# sudo --version

Error relocating /usr/lib/sudo/libsudo_util.so.0: getentropy: symbol not found

Is there any option to make it work except downgrade of firmware?

Thanks & Regards, Pawel

1 Answer

0 votes
by
Hi,

Unfortunately, there is nothing much we can do as it is a third-party package. I would imagine that some kind of library was changed and packages like sudo can't find the data that it hopes to find in that location. As it is a major update and only one package that is not working I believe changes will not be made unless there are more issues similar to this.

Also, could I ask you why do you need sudo?

EB.
by

Hi, the file is not missing - the library is there (/usr/lib/sudo/libsudo_util.so.0) however it has some missing symbol (getentropy: symbol not found). It might be that this 3rd party package will be updated at some point to work better on this version of OpenWRT.

I'm using sudo to switch from root to regular account to execute "gsmctl -c" or "gsmctl -l" commands - those read current modem temperature and signal strenght. I need to do it via sudo, as 2nd tool I use, which is "collectd" can execute scripts but not as root. Collectd is just collecting data in some intervals and plots some charts for me as statistics. Currently collectd is also not working on this latest firmware (I've logged separate post on the forum on this), so I have 2 issues to cope.

In case there is some solution for me please let me know.

Regards, Pawel

by
Hello,

I've had a similar issue with ssh (dropbear replacement, +scp etc) I had to recompile a package using the sdk. It should be possible to do the same for sudo.

Edit: I just built sudo this way, it works fine.

In the SDK directory:

./scripts/feeds install sudo

make menuconfig, go to Administration, enable sudo

make

You'll have a working package in build_dir.

Regards,