FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

12681 questions

15065 answers

24136 comments

47098 members

0 votes
493 views 10 comments
by

Hi, 

i'm running a RUT955 and RUTX08 with external Hotspot and i'm trying to configure Coova macauth. 

On the RUTX08 i used "uci set coovachilli.hotspot1.macauth=1" to enable macauth and this worked fine but when i use this on the RTU955 coova does not apply this. 

I can see set uci saved the config

root@RUT955:~# uci show coovachilli

coovachilli.hotspot1=general

coovachilli.hotspot1.profile='custom'

coovachilli.hotspot1.uamlogoutip='1.1.1.1'

coovachilli.hotspot1.mode='extrad'

coovachilli.hotspot1.radiusserver1='radius.cloudwifi.de'

coovachilli.hotspot1.radiusserver2='radius.cloudwifi.de'

coovachilli.hotspot1.radiusauthport='1812'

coovachilli.hotspot1.radiusacctport='1813'

coovachilli.hotspot1.radiussecret='XXXX'

coovachilli.hotspot1.uamport='3990'

coovachilli.hotspot1.uamuiport='4990'

coovachilli.hotspot1.uamsecret='XXX'

coovachilli.hotspot1.externalpage='1'

coovachilli.hotspot1.externadress='https://start.cloudwifi.de/'

coovachilli.hotspot1.net='192.168.2.254/24'

coovachilli.hotspot1.enabled='1'

coovachilli.hotspot1.macreauth='1'

coovachilli.hotspot1.macauth='1'

coovachilli.link=link

coovachilli.unlimited1=session

coovachilli.unlimited1.name='unlimited'

coovachilli.unlimited1.id='hotspot1'

coovachilli.url=url

But when i cat the Config itself i has not applied the config

root@RUT955:~# cat /etc/chilli/wlan0/hs.conf 

radiusserver1   "radius.cloudwifi.de"

radiusserver2   "radius.cloudwifi.de"

radiussecret    "XXX"

radiusauthport  1812

radiusacctport  1813

uamserver       "https://start.cloudwifi.de/"

radiusnasid     "nas01"

papalwaysok

uamlogoutip "1.1.1.1"

adminupdatefile "/etc/chilli/wlan0/local.conf"

uamsecret "XXX"

Is there any option to enable macauth on the RUT955? This would be very useful if the client has a longer surf time applied by the radius server.

1 Answer

0 votes
by

Hello,

What firmware version are you currently using ?

Is it latest ? if not please update to the latest first here and try .

Did you completed the configurations like :

uci set coovachilli.hotspot1.macauth='1'

uci commit coovachilli.hotspot1.macauth='1'

luci-reload 


Please try the following and check after reboot If it works or not ?

Regards,

Ahmed

by

Hi Ahmed,

thanks for your fast reply. Of course i committed the changes and reloaded luci but without luck...

We are currently running RUT9XX_R_00.06.07.4 on that device.

Best Regards,

Chris

by
Hello,

May i know after you use uci set command . Changes are made in the web ui or not ?

Because i have tested it on my side changes are made on the webui .

The issue is that only you are not able to see the config in cat ? Correct me if am wrong.

Have you tried this command
 

I am using cat/etc/config/coovachilli

Check if you are able to see the required config here ?

And if its about .conf Please use vi commands .

Thank you.
by
Hi Ahmed,

no i configured the device from web ui than changed the settings via uci + uci commit.

The issue is that macauth does not work. If a user gets 5min idle time + 30min surf time from the radius, uses 5min + 5min idle and than returns after some while, coova should use "macauth" to send radius request with the client mac without redirecting the client to the external start page. Coova usually generates the "main.conf" and "hs.conf" with all parameters needed from UCI or default.conf but if if cat hs.conf i don't see macauth in that file....so i assume, that coova is not using this parameter.

As i said, in my RUTX08 it's working fine with coova running on the LAN interface. Maybe this is an issue cause coova on the RUT955 is running on wlan0?

Best Regards,

Chris
by

Hi Ahmed,

i've just received 5 more devices for our project and tried the same on a fresh device. One with Firmware RUT9XX_R_00.06.07.3 and the other one with RUT9XX_R_00.06.07.4. Both did not apply the config to coova. I only used your UCI Commands after the initial Coova + WiFi Setup.

root@Teltonika-RUT955:~# uci show coovachilli

coovachilli.hotspot1=general

coovachilli.hotspot1.profile='custom'

coovachilli.hotspot1.net='192.168.2.254/24'

coovachilli.hotspot1.enabled='1'

coovachilli.hotspot1.uamlogoutip='1.1.1.1'

coovachilli.hotspot1.mode='extrad'

coovachilli.hotspot1.auth_proto='pap'

coovachilli.hotspot1.radiusserver1='radius1.cloudwifi.de'

coovachilli.hotspot1.radiusserver2='radius2.cloudwifi.de'

coovachilli.hotspot1.radiusauthport='1812'

coovachilli.hotspot1.radiusacctport='1813'

coovachilli.hotspot1.radiussecret='xxx'

coovachilli.hotspot1.uamport='3990'

coovachilli.hotspot1.uamuiport='4990'

coovachilli.hotspot1.uamsecret='xxx'

coovachilli.hotspot1.externalpage='1'

coovachilli.hotspot1.externadress='https://start.cloudwifi.de'

coovachilli.hotspot1.macauth='1'

coovachilli.link=link

coovachilli.unlimited1=session

coovachilli.unlimited1.name='unlimited'

coovachilli.unlimited1.id='hotspot1'

root@Teltonika-RUT955:~# cat /etc/chilli/wlan0/hs.conf 

radiusserver1   "radius1.cloudwifi.de"

radiusserver2   "radius2.cloudwifi.de"

radiussecret    "xxx"

radiusauthport  1812

radiusacctport  1813

uamserver       "https://start.cloudwifi.de"

radiusnasid     "nas01"

papalwaysok

uamlogoutip "1.1.1.1"

adminupdatefile "/etc/chilli/wlan0/local.conf"

uamsecret "xxx"

root@Teltonika-RUT955:~# ps | grep chilli

 4456 root      3992 S    /usr/sbin/chilli -c /etc/chilli/wlan0/chilli.conf

 8224 root      1540 S    grep chilli

root@Teltonika-RUT955:~# cat /etc/chilli/wlan0/chilli.conf

include /etc/chilli/wlan0/main.conf

include /etc/chilli/wlan0/hs.conf

include /etc/chilli/wlan0/local.conf

ipup=/etc/chilli/up.sh

ipdown=/etc/chilli/down.sh

root@Teltonika-RUT955:~# cat /etc/chilli/wlan0/main.conf

# THIS FILE IS AUTOMATICALLY GENERATED

cmdsocket       /var/run/chilli.wlan0.sock

unixipc         chilli.wlan0.ipc

pidfile         /var/run/chilli.wlan0.pid

net             192.168.2.0/255.255.255.0

uamlisten       192.168.2.254

uamport         3990

dhcpif          wlan0

uamallowed      "192.168.2.254"

uamanydns

domain "lan"

dns1 "192.168.2.254"

wwwdir /etc/chilli/www

wwwbin /etc/chilli/wwwsh

uamuiport 4990

adminuser "chillispot"

adminpasswd "chillispot"

conup "/etc/chilli/conup.sh"

condown "/etc/chilli/condown.sh"

If noticed, that the UI on the RUTX08 looks much newer/cleaner than on the other devices and the RUTX08 is running Coova 1.4.0 instead of 1.3.0. Will there be an Update for the RUT955 as well?

Best Regards,

Chris

by
Hello,

I will be consulting with the team.

Thank you for sharing the information.

Have a great day.
by
Hi Ahmed,

have you figured out something about this Problem ?

We have many customers, they use many of our Routers and they must re login too much times.
by
Hello,

Sorry for the inconvenience.

Once there is a news i will let you know.

Thank you for being patient.

Have a good day.
by

Hello,

 The issue is that configuration script ignores macauth option specified in the /etc/config/coovachilli file and as a result, generates /etc/chilli/wlan0/hs.conf without this option. Since MAC authentication is supported by CoovaChilli 1.3.0, only the configuration script needs to be changed. Nevertheless, this requires firmware modification.

So, you can modify the firmware by downloading SDK here . 

If you are not able to make it by yourself then its best to contact your sales manager. 

Have a good day.

by
Hi Ahmed,

thanks for your reply. We will change the needed scripts but i think that this change will not be persistent if we upgrade the firmware afterwards right? Are you planing to implement this to a future release of your firmware?

Best Regards,

Chris
by

Hello,

 We will change the needed scripts but i think that this change will not be persistent if we upgrade the firmware afterwards right? Yes

Are you planning to implement this to a future release of your firmware? No news for now regarding this. 

Thanks .

Regards,

Ahmed