6129 questions

7410 answers

11978 comments

7759 members

0 votes
61 views 2 comments
by

 Hi, I cannot send SMS with sms_send utility.

I have Teltonika RUTX11, firmware RUTX_R_00.02.06

I have tried unsuccesfully:

From web browser - http://X.X.X.X/cgi-bin/sms_send?username=smsuser?password=xxx?number=00420nnnnnnnnn?text=test

From web browser - http://X.X.X.X/cgi-bin/sms_send?username=smsuser?password=xxx?number=%2B420nnnnnnnnn?text=test

From linux command line:

curl -X GET "http://X.X.X.X/cgi-bin/sms_send?username=smsuser?password=xxx?number=00420nnnnnnnnn?text=test "

curl -X POST "http://X.X.X.X/cgi-bin/sms_send?username=smsuser?password=xxx?number=+420nnnnnnnnn?text=test "

X.X.X.X is LAN interface IP address.

xxx is not real password, the real one is more complex.

In all cases teltonika returns: Bad username or password

I can send SMS using gsmctl:

gsmctl --sms --send "00420nnnnnnnnn test"

gsmctl --sms --send "+420nnnnnnnnn test"

 Please for advice, thanks Ota

<!--[if gte mso 9]> Normal 0 false false false EN-US X-NONE X-NONE MicrosoftInternetExplorer4 <![endif]--><!--[if gte mso 9]> <![endif]--><!--[if gte mso 10]> /* Style Definitions */ table.MsoNormalTable {mso-style-name:"Normální tabulka"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-qformat:yes; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin-top:0in; mso-para-margin-right:0in; mso-para-margin-bottom:10.0pt; mso-para-margin-left:0in; line-height:115%; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-fareast-font-family:"Times New Roman"; mso-fareast-theme-font:minor-fareast; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin; mso-bidi-font-family:"Times New Roman"; mso-bidi-theme-font:minor-bidi;} <![endif]-->

1 Answer

0 votes
by
Hi,

How complex is your password? Have you tried using a simplified password and see maybe there's a symbol that might be not working within URL?

In any case, please try different users and passwords, change them into one without symbols, lets say using only letter characters.

EB.
by
Hi, I have tried many passwords incl. very simple ones.

Unsuccessfuy.

Ota
by

Could you just try using only CURL?

curl "http://X.X.X.X/cgi-bin/sms_send?username=smsuser?password=xxx?number=00420nnnnnnnnn?text=test"

EB.