10886 questions

12975 answers

20228 comments

26222 members

0 votes
191 views 2 comments
by

Hi,

I am trying to use "Modbus Data to Server" function of RUT955 to collect Data from Modbus slave/server via Modbus TCP, and use MQTT Bridge to send Modbus Data to Schneider Machine Adviser cloud platform. 

I could not fill the correct info into the following two fields at MQTT Bridge setting page: (When I use TRB245 to send Modbus data to Schendier Machine Advisor, the same two fields have no issue to be filled.)

"Remote Username"

"Remote Password"

Would you please help to check this. 

Thanks.

1 Answer

0 votes
by
Hello,

Regarding this issue of yours could you try just putting test in username and password.

Then executing this command in CLI:

uci set mosquitto.mqtt.remote_username=username here
uci set mosquitto.mqtt.remote_password=password here
uci commit mosquitto
/etc/init.d/mosquitto restart

Let me know the results.

Regards,

Jerome
by

Hello Jerome,

Just tried the following lines in CLI:

uci set mosquitto.mqtt.remote_username=username here

uci set mosquitto.mqtt.remote_password=password here

uci commit mosquitto/etc/init.d/mosquitto restart    (please check should be like this in one line?)

Outcomes: Still not working.

  --- The username filed has been filed (but still showing a red boarder on the filling filed.)

  --- The password filed is still filled with "test", not been updated.

Kind Regards,

JP

by

Hello JP, 

I would recommend filling up the things in web ui first with any username as long as it has no space, in the same way do it in the password field. After that save the settings. 

Now go to CLI run this code one by one doesn't copy-paste them all. 
-> uci set mosquitto.mqtt.remote_username=azure link
-> uci set mosquitto.mqtt.remote_password=password from azure
-> 
uci commit mosquitto                              -------> this is a different line
-> /etc/init.d/mosquitto restart                     -------> this is a different line

I will be informing HQ about this username password limit in MQTT bridge username password field. I will let you know their feedback 

Regards,
Jerome