7619 questions

9052 answers

14602 comments

11927 members

0 votes
2,106 views 9 comments
by
Hi,

how do I activate the call reboot through the UCI SMS API?

//klaus

1 Answer

0 votes
by

Hi,

You can't add a new rule, but you can enable/disable a rule with:

uci set call_utils.@rule[0].enabled='1'

Take note that different rules have different numbers (I highlighted the rule number in the example). If you have multiple rules, you can send this message to find out their numbers:

uci show call_utils

by
Hi,

when I send the command "uci show call_utils" to the RUT950, I get the below response.

call_utils.call.ringing=0

call_utils.call.reject_incoming_calls=1

call_utils.call.enabled=1

//klaus
by
It means there is no Reboot rule configured. As I mentioned earlier, it is not possible to add the rule via SMS.
by

Hi again,

where do I add my own mobile number? Is the mobile number like below defined inside the brackets?

uci set call_utils.@rule[+358123456789].enabled='1' 

//klaus

by
Ok. Thank you for your help. Do you know if I can set the periodic reboot via UCI? I have problems accessing the router remotely, because the SMS command reboot doesn't work in the v. 00.05.03.4, so I need some other way to reboot the router remotely. The SMS cellular command takes effect only after the router has been rebooted.
by
Hi,

forget it. I cannot change any settings via UCI even though I get the response "Replaced existing value..." from the router, After I got the response I send  the command uci commit to the router, but the value stays the same.

I think I have to wait until spring when I will physically be at the same place as the router.

//klaus

//klaus
by
Is your router connected to RMS?
by

Hi,

unfortunately not, because the monitoring_status is disabled. I cannot activate the monitoring through the "monitoringon" command, because the router doesn't register any changes. I'm starting to believe that the flash on the router isn't working proberly.

//klaus

by

So if I understand correctly, you were trying to set APN on your router with the cellular message in order to get remote access to the router? If so, the cellular message doesn't really require a reboot. I suppose something could be wrong with the router and the settings didn't apply for some reason. In that case you can try not rebooting the router, but restarting the mobile data connection with mobileoff and mobileon messages.

by
Correct. I will today try to configure the router from another RUT router.

//klaus