subscribe to our Youtube


14455 questions

17168 answers


0 members

We are migrating to our new platform at Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
+1 vote
414 views 3 comments
by anonymous
Hello all:

Previous to yesterday, with our new batch of 130 RUT950 units(which were delivered wit FW 7.5, , when we did a "opkg update" and then "opkg install openssh-sftp-server" and "opkg install ip-full --force-overwrite" everything worked fine.

Now none of those commands works as something has gone wrong with the website.

From a commercial standpoint, our decision to go with the RUT950 was that it could be configured as a drop-in replacement for the Digi WR21....which we were able to do using a tap0 interface, however; the off-the-shelf RUT950 uses a cut-down version of the iproute2 package (which I find curious being that the RUT950 is a router, surely a router would "need" the full iproute2 package?). Never mind, we absolutely require the full iproute2 package as we need the tap0 interface.

We need the opnssh-sftp-server to push config files onto the router....we have hundreds of routers, we cannot manually config via the webUI......which for us does not work anyway due to the tap0 requirement.

We setup our IPSec tunnels using GRE inside IPsec so we do this from the /etc/rc.local file, example:

root@CORS270:~# cat /etc/rc.local

# Put your custom commands here that should be executed once

# the system init finished. By default this file does nothing.

ip tuntap add name tap0 mode tap

ip addr add brd + dev tap0

ip tunnel add SOI mode gre remote local ttl 255

ip link set SOI mtu 1400

ip link set SOI up

ip addr add peer brd + dev SOI

sleep 5

/etc/init.d/ipsec restart

sleep 10

ip route del

sleep 2

ip route add dev SOI

exit 0

I short, we MUST HAVE the ip-full package and the openssh-sftp-server packages and we are no longer able to get those from

We need a solution to this else we must return the RUT950s and go back to the Digi WR21 units. We have projects that will require approximately 500 more RUT950 units but if this is a permanent problem, we'll have to go back to Digi.

This is both a technical and commercial issue.


by anonymous
Hi All:

This issue is resolved, the Openwrt guys got the archive server back up and running.

Is there a way I could  mirror locally the:


Updated list of available packages in /var/opkg-lists/chaos_calmer_base.


Updated list of available packages in /var/opkg-lists/chaos_calmer_packages.


Updated list of available packages in /var/opkg-lists/chaos_calmer_luci.

Locally so that I could avoid this issue in the future?



2 Answers

0 votes
by anonymous

Glad you solved your own issue.

Have a nice day.

0 votes
by anonymous

Hi John,

I was facing the same issue today (got gateway error 502) and decided to whip up a little script to mirror the repository.
It does synchronous downloading and md5sum checking, so it may take a while to pull the whole repository.

Hope it helps

ps. Once the mirroring is complete, you may adjust /etc/opkg/distfeeds.conf ds.

by anonymous
How large is the repository when you mirror it?


by anonymous
46M     chaos_calmer/15.05.1/ar71xx/generic/packages/base           (1002 ipk) 
5.1M    chaos_calmer/15.05.1/ar71xx/generic/packages/luci            (960 ipk)
236M    chaos_calmer/15.05.1/ar71xx/generic/packages/packages        (1948 ipk)
286M    chaos_calmer/15.05.1/ar71xx/generic/packages  <- Grand total (3910 ipk)

Plus 1 Package.gz for each directory, so 3913 all in all.
Script updated