8401 questions

9888 answers

15684 comments

14166 members

0 votes
160 views 11 comments
by

I have a strange behavior of my RUTX12 device. It works as expected for a short period of time (30 - 60 minutes) and then suddenly things go south. Certain services just stop working. Looking into the log file I saw that it is filled up with just one error message:

daemon.err ledman[3325]: Failed to find gsmd ubus object

As the services that stop working have to do with communication this explains things. For example the RMS does not get all the details about the device anymore. It does not show the correct mobile status just as a simple example. Other services such as GPS also stop send the details to the server.

I‘m running the latest firmware 2.06.1.

Any thoughts or advise?

Many thanks, Michael

 

by
Has this been resolved - sound much like my issue with my RUTX12...
by
Same issue here, possibly related to latest FW release...Mobile service down which is worse case issue. Looks like you're having a lots of troubles with modems on this device. Not to mention constant disconnections from ttyUSB due to this other HW issue. How can this be on that sort of high-end equipment ?

1 Answer

0 votes
by

Hello,

Could you try to re-flash your router firmware via the bootloader menu to the latest version. Please follow these instructions: https://wiki.teltonika-networks.com/view/RUTXxx_Firmware_via_The_Bootloader_Menu

Also, when some of the services stop, do you still have access to the outside network via a mobile interface (can you ping google or other page from router CLI)? It may require upgrading your modem firmware too.

Regards.

by
Hi, I did re-flash the router firmware via the bootloader to the latest version a few times already.

Yes, I still have access to the outside network, can ping google from CLI, can access it remotely via the RMS, etc. It‘s just that some of the services stop communicating and the error message comes up.
by
It seems that two services are causing this issue and the associated error messages. The gpsd and gsmd are no longer visible when I list the associated services registered to the ubus service. This is consistent with the problems I‘m encountering. Question is how to find out what is really going wrong here as what I described earlier is just the symptom but most likely not the cause.
by
Hi,

It seems this issue is caused by the modem only, could you send me your router troubleshoot file via private message to verify the issue? You can download Troubleshoot file by navigating WebUI > System > Administration > Troubleshoot.

Regards.
by
Hi Vykintas, did you get my PM from a couple of week back? I do agree with you that the modem seems to be the route case of this. Thanks for your guidance what I can do to get this fixed.

Many thanks,

Michael
by
The moment I add a second SIM card and use the second modem as failover, the error messages go away and everything comes back to normal. How can this be? I can also see that it fails over a lot to the second modem only to come back to the first one rather quick. It has nothing to do with the actual connection because I also swapped the SIM cards. To me this points more and more to an issue with modem 1.
by
Hello,

Could you check your modem firmware version and post it here? It looks like modem 1 is malfunctioning and re-installing it may solve the issue.

Regards.
by

Hi, the problem has vanished after one of the last updates I made. Tried several times to re-install all firmware and at some point it worked. At the moment this is what I'm running. Not sure if I want to do any more updates as every time something stops working. Had so many issues with this device ... :-(

Firmware version: RUTX_R_00.02.06.1

Primary Modem Firmware Version: EG06ELAR04A03M4G

Secondary Modem Firmware Version: EG06ELAR04A04M4G

by

Same struggle than you Bulli, so many issues on this product line. If one thing is stable this in my consumer grade 4G Huawei WAN :-(. Guys at Teltonika you should reflect on what you do want to achieve with the RUTX12 at this point...clients are not dump and will necessarily move away.
 

ri Aug 13 15:31:38 2021 daemon.err ledman[4800]: Failed to find gsmd ubus object

Fri Aug 13 15:31:48 2021 daemon.err ledman[4800]: Failed to find gsmd ubus object

Fri Aug 13 15:31:58 2021 daemon.err ledman[4800]: Failed to find gsmd ubus object

Fri Aug 13 15:32:08 2021 daemon.err ledman[4800]: Failed to find gsmd ubus object

Fri Aug 13 15:32:18 2021 daemon.err ledman[4800]: Failed to find gsmd ubus object

Fri Aug 13 15:32:28 2021 daemon.err ledman[4800]: Failed to find gsmd ubus object

Fri Aug 13 15:32:38 2021 daemon.err ledman[4800]: Failed to find gsmd ubus object

Fri Aug 13 15:32:48 2021 daemon.err ledman[4800]: Failed to find gsmd ubus object

Fri Aug 13 15:32:58 2021 daemon.err ledman[4800]: Failed to find gsmd ubus object

Fri Aug 13 15:33:08 2021 daemon.err ledman[4800]: Failed to find gsmd ubus object

Fri Aug 13 15:33:18 2021 daemon.err ledman[4800]: Failed to find gsmd ubus object

Fri Aug 13 15:33:28 2021 daemon.err ledman[4800]: Failed to find gsmd ubus object

Fri Aug 13 15:33:38 2021 daemon.err ledman[4800]: Failed to find gsmd ubus object      

AND well known one: over 40 times droped modem1 in 24 Hours....

[135437.297920] option1 ttyUSB4: GSM modem (1-port) converter now disconnected from ttyUSB4

[135437.301644] option 3-1:1.0: device disconnected

[135437.310259] option1 ttyUSB5: GSM modem (1-port) converter now disconnected from ttyUSB5

[135437.314415] option 3-1:1.1: device disconnected

[135437.322837] option1 ttyUSB6: GSM modem (1-port) converter now disconnected from ttyUSB6

[135437.327059] option 3-1:1.2: device disconnected

[135437.335465] option1 ttyUSB7: GSM modem (1-port) converter now disconnected from ttyUSB7

[135437.339780] option 3-1:1.3: device disconnected

[135437.456635] qmi_wwan 3-1:1.4 wwan1: unregister 'qmi_wwan' usb-xhci-hcd.1.auto-1, WWAN/QMI device

[135449.375686] usb 3-1: new high-speed USB device number 7 using xhci-hcd

[135449.563787] option 3-1:1.0: GSM modem (1-port) converter detected

[135449.564108] usb 3-1: GSM modem (1-port) converter now attached to ttyUSB4

[135449.569723] option 3-1:1.1: GSM modem (1-port) converter detected

[135449.576160] usb 3-1: GSM modem (1-port) converter now attached to ttyUSB5

[135449.582835] option 3-1:1.2: GSM modem (1-port) converter detected

[135449.589422] usb 3-1: GSM modem (1-port) converter now attached to ttyUSB6

[135449.595726] option 3-1:1.3: GSM modem (1-port) converter detected

[135449.602129] usb 3-1: GSM modem (1-port) converter now attached to ttyUSB7

[135449.627264] qmi_wwan 3-1:1.4: cdc-wdm1: USB WDM device

I don't have easy critics but this starts to be enough. I'm on my second warranty replacement device and the second was actually worse than first. 

by
Julian, could not agree more with what you said. There are so many thinks that (still) don't work. Rather than coming up with new devices  that just have slight variations might be a good idea to get the ones on the marked fixed first.

Anyway, I'm already looking for alternatives as this was always a sort of temporary solution for me for a few years anyway. That's because of the supported regions of the modems. I knew this but wanted to try this device out as for the next two years or so I'm still good. Beyond that I always knew I had to get a new device to have all WW regions covered with the build in modem.

Let's see what device it will be. My experience with this company and this device is certainly not very good so far ...