FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
782 views 8 comments
by anonymous
Hello,

I have my TRB140 setup in IP Passthrough mode which is passing the WAN IP through to my firewall fine.

I would like to be able to access the WebUI from the network, but this device only has one NIC which is being used for WAN. I have tried creating a VLAN and attaching it to eth0 and bridging to LAN1, but i can't seem to get any device to be able to see it at 192.168.2.1

What configuration would i need to have setup on the TRB140 to assign a VLAN to the eth0 interface to enable to have both WAN & LAN access over it?

Thanks

Oliver

1 Answer

0 votes
by anonymous
Hello,

As default when you are going to use passthrough mode in Mobile configuration, you are assigning the SIM card IP to another LAN device connected to the TRB140. Now kindly correct me if I am wrong you are assigning the IP address of the SIM card to your firewall and retaining the DHCP functionality of the TRB140 on 192.168.2.0/24 correct? What you want to achieve is you want to allow the devices below the firewall to reach the TRB140 correct?

Kindly give me more information if the mentioned things on my side is not correct.

Regards,
Mellow
by anonymous

Yep that pretty much it. I have included a diagram below to try and explain it better.

The IP Passthrough is working as the firewall gets the WAN ip of the 4g Modem, but i don't seem to be able to get any traffic for the LAN vlan working.

I have created a VLAN

And attached that VLAN to the LAN interface

by anonymous

Hello, 

Sorry for the late reply.

Tried replicating this on my side my set up is like this: 


Using passthrough mode as default, the device connected in RUTX11 is able to reach the TRB140 LAN IP without any VLANs configured. 

So now, I would like to check if the scenario you want to make is you want to have a network where both the Firewall network and TRB140 network will be able to communicate? And you need also to have VLAN's enabled for this one? 

Kindly confirm :) 

Regards,
Mellow

by anonymous
Hi Mellow,

I am using this as my failover network so my default gateway currently point to my broadband line. The problem is when i have the device in IP passthrough my firewall doesn't know how to get to 192.168.2.0/24 as it doesn't have an interface/route in that network. What i wanted to do was to create another vlan that i could add an interface in for my firewall so it would know how to route traffic to 192.168.2.1.

I believe if my default gateway was to send traffic to the TRB140 it would probably work as the TRB140 would answer the request, but as it isn't my firewall is going to send all unknow traffic out to my broadband line (which is currently my default route).

I also thought that i could add a static route on my firewall to send traffic for 192.168.2.0/24 to the TRB140, but when its running in IP passthrough mode the TRB140 doesn't seem to have an IP address that i could use for the next hop for the route on the firewall.

Regards

Oliver Knights
by anonymous
Hi,

Currently, our HQ is checking this issue for VLANS in TRB140. I will let you know once I receive feedback from them.

Regards,
Mellow
by anonymous
Hello,

Regarding the VLAN issues here is the link for the test firmware where VLAN configuration is fixed for TRB140: https://mega.nz/file/ilEWiZ6I#FNuWh8W7hsuaok0EcPGAxXWtlVHQMKu-msj7MpjqYs0

Just re-flash the firmware of your TRB140 without keeping the settings and configure the VLAN config as you require.

Let me know the results

Regards,
Mellow
by anonymous
Hello Mellow,

I have installed the test firmware and i can confirm that the VLAN option is now working. Thank you

Regards

Oliver Knights
by anonymous
Hi Mellow,

The test firmware is working fine for me in regards to VLAN's, however DHCP seems to have stopped working for any interface?

I have put devices in both the default LAN and my VLAN network and neither get a DHCP address. If i set a static address everything works fine. I have made sure the DHCP server is enabled on both the default LAN interface and my VLAN interface. This was working fine before using the test firmware.

If i disable Passthrough on the mobile interface DHCP starts working for allow networks.

Regards

Oliver
by anonymous
Hello,

Could you send us a copy of the troubleshoot file of the said device. Just to clarify things the said firmware was working fine for like a month then it suddenly stopped? Did you alter or made some other configurations after the past month?

Let me know :) You can communicate with me via PM also for this.

Regards,
Mellow