FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
0 votes
920 views 19 comments
by anonymous
Hello,

I am using an RUT240 to create Modbus Master Alarm by SMS.

In Alarm settings i can enter my phone number and the settings can be saved without any problems.

In the Modbus Master Alarms overview i can enbale or disable the created alarms. After pressing the save button i get teh follwoing error message:

Empty phone number, unable to enable the alarm

The phone number is use has been testetd by creating and sending a test sms via the RUT240.

Does anyone has a suggestion how to solve it?

Bes regards

1 Answer

0 votes
by anonymous
Hello,

May i know what is the firmware on the device ?

Are you using the latest firmware ? If not please upgrade and try again .

https://wiki.teltonika-networks.com/view/RUT240_Firmware_Downloads

Thanks.

Regard,

Ahmed
by anonymous
Hello,

Thank you for the fast response. I have updated the firmware, but still same problem

Best regards
by anonymous
Hello,

I have tested it on my side and unfortunately i wasn't able to replicated the issue on my side. I was able to save the phone number with different formats (with country code, without country code etc).

Is it possible to share a short video or screenshot for this event . So that i can get a more clearer picture of the issue you are facing.

Thanks.
by anonymous

Hello, 

I enable the alarms in the overview (picture one) When i press the save button the following messages apears (picture two) 

Anyhow, i have managed to receive sms but only if i use register one. If i use any other register the choosen condition does not work and no sms is send. Is that how it should be?

Furthermore, to add and edit another sms alarm is only possible if the all other sms alarms are disbaled. Is that how it should be?

Best regards

Modbus Master Alarms are EnabledAfter pressing Save-Button the following messages apears

by anonymous
Hello,

Could you please share a troubleshoot file for this event you stated above ?

I have tried it on my side its showing the same.

Thanks
by anonymous
Hello,

I am sorry for not knowing. But how do i do it?

Do you mean create a new question?

Best regards
by anonymous

Troubleshoot file could be downloaded from System>Administration>Troubleshoot

If device isn't rebooted there must be logs for this event in this log file. 

After the reboot logs are lost.

Thanks. 

by anonymous
Thanks .

Will update you.
by anonymous
Thank you

Best regards
by anonymous
Hello,

The issue was reproduced and forwarded to R&D.

Thanks.
by anonymous
Hello,

Regarding the issue.

Its already forwarded to R&D .

I would request you to individually save settings for each alarm until there is an update from R&D.

For the sms related part i was able to receive messages for the different multiple register values.

Thanks .
by anonymous
Hello,

can you send me a screenshot of the page: Advanced device settings and Modbus Master Alarms overview?

Thank you

Best regards
by anonymous
by anonymous
Hello,

thank you

This helps a lot

Maybe one screenshot of the Modbus TCP master configuration. Special focus on Slave device configuration and Requests configuration
by anonymous

Hello,

Screenshots for Modbus master and slave is here:

https://community.teltonika-networks.com/?qa=blob&qa_blobid=12460536921290936585

Thanks.

by anonymous
Hello,

thank you. I was able to send an sms alarm.

Best regards
by anonymous
Hello,

Happy to hear.

Regarding the other issue on overview part for number, i think it doesn't effects the performance or doesn't stops any functionality but still its an issue and that's why its already on R&D. So, when there is a news i will update you.

Thanks.
by anonymous
Hello,

The issue would be fixed in the next firmware release.

Keep yourself updated .

Thanks.
by anonymous

Hello,

The issue has been fixed in the new firmware release:

Please let me know your feedback.
Thanks. 
Regards,
Ahmed