7012 questions

8394 answers

13631 comments

10306 members

0 votes
72 views 8 comments
by

Goodmorning,

I am using a RUTX10 with firmware RUTX_R_00.02.06.
RUTX10 is connected using ethernet to some device without Wifi adapter.
This Device  have this ip class: 20.30.x.x/16
RUTX10 has this ip: 20.30.249.250/16.
RUTX10 will be wifi connected to a SSID generate by another router with DHCP server.
This Router has: 192.168.1.1/24.
A PC(20.30.1.1/16) connected to exixting router using lan needs to comunicate with my device connected with rutx10.
I tried using wifi client mode and relayd.
The system works only if device and rutx10 are in the same class ip of the existing router (192.168.1.x/24)
RUTX10 should be trasparent from LAN to wifi.





 

1 Answer

0 votes
by

Hi.

If your "router" is using DHCP server.

  • Your "PC" should get an IP from 192.168.1.0/24 subnet.
  • Your RUTX10 should get an IP from 192.168.1.0/24 too.
If your RUTX10 has disable its own DHCP server and enabled the DHCP Relayd. Your "PLC Device" should get an IP from 192.168.1.0/24 too.
In this way all the devices should connect between them.
On other hands, if you want to use Router with subnet 192.168.1.0/24 and RUTX10 with 20.30.1.0/16.

You can maintain the RUTX10 with DHCP enabled and Relayd disabled. And use a static route bettween both subnets.
https://wiki.teltonika-networks.com/view/RUTX10_Routing#Static_Routes

Any further doubt, please let me know.

Regards.
by
Thank you!

Can you send me a example of a static route bettween both subnets ( 20.30.x.x/16 and 192.168.1.x/24)?
by

Hi,

Basically, you need to select your `Target`, a subnet, select the mask and a gateway.

You can try using

Target: 192.168.1.0 / Mask: The mask you want to use / Gateway: 192.168.1.1

https://wiki.teltonika-networks.com/view/RUTX10_Routing#Static_Routes

These are another crowd support cases regarding to this topic.

https://community.teltonika-networks.com/31558/rutx10-client-mode-with-different-ip-class

https://community.teltonika-networks.com/20467/static-route-not-added-and-not-working?show=20467#q20467

In the same way, the firewall is iptables, if you want to learn more about it, you can read 

https://openwrt.org/packages/pkgdata/iptables

Regards.

by

The interface of the static route is lan or wlan. I think wlan. Right?

In the first comment you say: “You can maintain the RUTX10 with DHCP “ (lan interface?) i think this in not mandatory.

Thank you very much for your help and for your patience.

Regards.

by

Hi,

The interface of the static route is lan or wlan. I think wlan. Right?

  • By default, LAN & WLAN are in the same subnet.

In the first comment you say: “You can maintain the RUTX10 with DHCP “ (lan interface?) i think this in not mandatory.

  • It was only an additional comment, so each solution can be needing some specific configuration.
Could you solve the issue? or still needing help?
Anything else please let me know.
Regards.
by
I have done this steps:
1) put RUTX10 LAN this ip: 20.30.249.250/16.
2) Disabled DHCP on LAN interface
3) Under wireless tab joined router SSID. (firewall zone wan)
4) NOT Relayed under lan interface.
5) WWAN interface with DHCP enabled
6) Create two static routing rules on RUTX:
          -  INTERFACE: Lan TARGET: 192.168.1.0 NETMASK: 255.255.255.0 GATEWAY: 192.168.1.1 TYPE: Unicast
          -  INTERFACE: Lan TARGET: 20.30.0.0 NETMASK: 255.255.0.0 GATEWAY: 192.168.1.1 TYPE: Unicast.

On "router" i cant do anything .
PC can't ping PLC device. Can you tell me where is my fault.
Thank you for your help.
by
Hello,

You disabled DHCP on LAN and also disable the DHCP relayd in your LAN interface.

Did you put static IP's to your PLC/PC connected to the router? Remember that IP's are assigned with DHCP, if you disable it, you need to set up your devices with static IP's into the subnet.

Regards
by

Yes i put static IP.
On PC: 20.30.1.1/16 no gateway
On PLC device: 20.30.1.160/16 no gateway.

Are right this two rules on RUTX10?
          -  INTERFACE: Lan TARGET: 192.168.1.0 NETMASK: 255.255.255.0 GATEWAY: 192.168.1.1 TYPE: Unicast
          -  INTERFACE: Lan TARGET: 20.30.0.0 NETMASK: 255.255.0.0 GATEWAY: 192.168.1.1 TYPE: Unicast.

Thank you

by

Hi,

You should tell to your PC/PLC to which IP they should return the packages, without gateway, they will lost the packages due they don't know to which IP should send.

Are right this two rules on RUTX10?

Seems they're right, but I can't be sure of your topology and the connections you already have in your network. My suggestion is to add devices and test them one by one until you get your goal.

Also,

  • Why did you disable DHCP on second router?
  • Why did you set up PC/PLC without gateway?
At this moment i'm a bit lost due the changes you mentioned above. What steps did you get successfully and how can we help you from now?
Regards.