FOR TIPS, gUIDES & TUTORIALS

subscribe to our Youtube

GO TO YOUTUBE

14455 questions

17168 answers

28195 comments

0 members

We are migrating to our new platform at https://community.teltonika.lt. Moving forward, you can continue discussions on this new platform. This current platform will be temporarily maintained for reference purposes.
+1 vote
407 views 1 comments
by anonymous

Hi all,

my company uses the RUT950 and RUT240, with the RUT950 I never had problem with the APNs of different providers, the internet always worked.

Bit with RUT240 for my Telekom and some other operator simcards the internet is not working. I found out that this is because the APN is not set, If I set the APN manually it works. The same cards work at the RUT950 immediatly.

What also is strange, if I set in the file /etc/config/simcard option force_apn 'random number' and comment option auto_apn '1', then it works with all cards and it sets the correct APN. I thought the option force_apn is to set a static records out of the APN database.

Can you please help me.

I was determined this with version: RUT2XX_R_00.01.14

here is an abstract from the log

https://pastebin.com/raw/dMJj1AKZ

by anonymous

Hi Wolfgang and Teltonika,

I had the same issue, using the latest firmware 14.3 and rut240 the auto APN function is not always working correctly it is connected to the network but the internet connection is not established.

I first though my configuration was not good and I defaulted it but that didnt help, after that I tried the same simcard with 2 different rut240 new out of the box with the same results.

After changing the APN settings (can be done by sms) it is getting online instantly.

Just for everyone else having trouble use the SMS command: [password] cellular apn= [APN] and after 2minutes perform a reboot of the device to activate the new settings. [password] reboot

2 Answers

0 votes
by anonymous
Hello,

Could you provide a list of APN's that does not work with the Auto APN feature and do work when you change the config file?

Regards.
0 votes
by anonymous

Hi,

thanks for the quick reply. Please see the following list with APNs. If I use following option inside simcard config, then the device sets all the APNs and it works.

/etc/config/simcard

option force_apn '1234334'
#option auto_apn '1'

see correspondig logread

https://pastebin.com/raw/0vXLw2FA


If I use the default values inside simcard config like shown below, then it does not set any APN

/etc/config/simcard

#option force_apn '1234334'
option auto_apn '1'

see corresponding logread

https://pastebin.com/raw/swD01rpg

Operator: O2

option apn 'internet'
option auth 'none'

Operator: ja! mobil & Telekom

option apn 'internet.telekom'
option username 'telekom'
option password 'telekom'
option auth 'pap'

Operator: ALDI TALK

option apn 'internet.eplus.de'
option username 'eplus'
option password 'internet'
option auth 'pap'

Thanks in advance!

Best regards
Wolfgang