11384 questions

13563 answers

21250 comments

31889 members

0 votes
165 views 0 comments
by

I have a setup with TRB140 and some serial/tcp converters. I have port forwarding setup to access the serial port via openvpn at the router ip

First it was configured in  192.168.0/24 range and working properly, then I reconfigured the range to 192.168.178/24 and edited respectively

dev_5_port_1 IPv4-tcp, udp

From any host in openvpn

Via any router IP at port 15101
IP 192.168.178.115, port 101 in lan


but now when i connect to ovpn_ip:15101, i am not connected to the serial port

If i create the ssh tunnel through router, it works, so the device is definitely reachable

What did I forgot to change, or what need to be checked to make it work?

Thanks

1 Answer

0 votes
by
Hi,

Just to make sure. Could you go and change the rule again to 192.168.0.. to avoid the chance that the rule maybe isn't saving in.

If it works as it worked, the next thing you could do is check if your routes are pushed correctly and there's nothing you missed in OpenVPN config that could be still bound to the 192.168.0/24 range.

If you're still unable to find the issue - try restarting your router or resetting it to default factory settings but set up the new IP first and then set up OpenVPN from the beginning.

EB.