8764 questions

10413 answers

16347 comments

15479 members

0 votes
72 views 0 comments
by

Hi to all, I'm having strange behaviour of my RUT955 (firmware updated to latest available RUT9XX_R_00.06.07.7, nothing changed).

I have two operators: TIM and WIND.
TIM hasn't got so good coverage among mountains, so I moved to WIND and I started making some test...

I usually get good signal strength (-57, -61 dB) in 3G or 4G.

Registered (home); WINDTRE; 4G (LTE), -69dB signal strength

wwan0     Link encap:Ethernet  HWaddr 3E:63:D4:70:86:81
           inet addr:10.0.76.189  Bcast:10.0.76.189 Mask:255.255.255.252
           inet6 addr: fe80::3c63:d4ff:fe70:8681/64 Scope:Link
           UP BROADCAST RUNNING NOARP MULTICAST  MTU:1500 Metric:1
           RX packets:5 errors:0 dropped:0 overruns:0 frame:0
           TX packets:182 errors:0 dropped:0 overruns:0 carrier:0
           collisions:0 txqueuelen:1000
           RX bytes:1480 (1.4 KiB)  TX bytes:14843 (14.4 KiB)

root@Teltonika-RUT955:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use
Iface
default         10.0.76.190     0.0.0.0         UG    0 0        0 wwan0
10.0.76.188     *               255.255.255.252 U     0 0        0 wwan0
192.168.83.0    *               255.255.255.0   U     0 0        0 br-lan
root@Teltonika-RUT955:~# ping 8.8.8.8

PING 8.8.8.8 (8.8.8.8): 56 data bytes

^C

--- 8.8.8.8 ping statistics ---

2 packets transmitted, 0 packets received, 100% packet loss

root@Teltonika-RUT955:~#

The same if I use www.google.com instead 8.8.8.8.
No change if I set auto/custom APN or if I force 3G only/4G only.
No change setting manually B1, B3, B20 bands.
"Force LTE network" checked/unchecked, no changes.

Using different operator (TIM) all is correctly working, just I get -103dB in WCDMA.

To make WIND working I need:
- manually  run "Status -> Network -> reboot modem"
or
- manually run "/etc/init.d/network restart" in terminal

Simple reboot (due to ping watchdog or SMS reboot command) doesn't solve issue.
My first solution would be to create a script to restart network after boot but it shouldn't be so....

Any idea?
Thanks.

Thanks.

1 Answer

0 votes
by
Hi,

It could be that the operator is handshaking with the modem before the modem has time to boot up, so in this case, you should see if there's anything possible to do with the operator and maybe they can send some kind of reinitiation of registration.

Or, as you said, you can put up a command on boot, which will restart your network service.

You can do that by going to System > User Scripts and enter your command there.

EB.