11384 questions

13563 answers

21250 comments

31888 members

0 votes
397 views 8 comments
by
by
OK have tried this with the rut240 and was able to connect to web server on PC using port 80, still cannot connect to device on port 80 but can do so on port 80 using TRB140 strange but true. Nice little tool by the way.
by
Hi.

I am having the exact same problem.

I want to do a port 80 forward to a device on the LAN.

No matter what I try I just can't get it to work. I am not able to change the listening port on the LAN device, so the port forward must go to port 80.

The WAN IP I have is of course a public one, and I have tried to do a forward from WAN 36444 to LAN Device IP port 80.

Am I missing something?

At the top of the thread there is a note in BOLD stating this:

Solution is this:

uci set firewall.@zone[0].mtu_fix='1'

uci commit firewall

/etc/init.d/firewall restart

But I have no idea what to make of that, and wether that is actually the solution that will make it possible to forward to port 80 on a LAN IP.

Thanks in advance.

rco133

2 Answers

0 votes
by

Hello, 

First of all for this issue of I would like to confirm what type of  WAN IP address is your RUT240 having? You can double-check that by referring to this link: Private and Public IP Addresses - Teltonika Networks Wiki (teltonika-networks.com). Also, there are some cases our clients using VPN solutions are you also using one? Because you only shared basically no information on what are you trying to do. 

Now if you are having a Public IP address make sure  you properly configured the port-forwarding rule you can refer to this link for more information: RUT240 Firewall - Teltonika Networks Wiki (teltonika-networks.com)  

Solution is this: 

uci set firewall.@zone[0].mtu_fix='1'
uci commit firewall
/etc/init.d/firewall restart



Regards,

Mellow

by
Sorry I did not mean to post this until I had added all info, not sure what happened, but here is my situation, I use predominately the TRB140 and RUT950 I have a number of uses for these mainly remote plant management and meter readings. The TRB140 I use to monitor heat meter output using a Three Sim and DYNDNS address I manage the device on port 90 and use port 80 to point to my meter reading device and this works great, I have to use port 80 otherwise my device does not work, I also use the RUT950 for plant management readouts and use port 80 to manage the router and port 90 to point to the plant controller, also using three sim and DYNDNS. All works great, however I would to replace the TRB140 with the RUT240 and find that although I can change the management port to port 90, if I try to route port 80 to my device it does not work, I get error 0 on the top left corner of the screen. This same situation happens if I try to do the dame thing on the RUT950. I have been asking for help with this for over a year and have no solution. The reason I want to use the RUT240 is the second port which can be used for network also and would be a useful trouble shooting port in the field. I have hit my head against a brick wall with this for best part of a year, tried numerous tricks and nothing works. Any help would be greatly appreciated.
by

Hello, 

For this issue of yours, I would really suggest testing it manually. So the suggested testing is to try to use the same sim card on RUT240 and DDNS configuration as TRB140. Now connect a laptop/pc to RUT240 were running this program HFS ~ HTTP File Server (rejetto.com) this is much easier because you can change to different ports for the webserver. Now do the port-forwarding rule on RUT240 and check if you are not able to reach the HTTP File Server that is running on your laptop. Just keep in my it would be best to disable the firewall of your laptop/pc during this testing to prevent some interruptions. 

It is also best to check if something is already running in port 80 that is why it is not able to forward the packet to another port. 

If you need assistance in doing this let me know. 

Regards,
Mellow

by
Yes all setting are the same on both devices using same DNS etc.  A point of observation if you try to use the Mobile ISP DNS servers you will not get port forwarding at all using dyndns. I always change this to google or open dns. I will try your suggestion and get back with results, may not be today but really appreciate the input.
by
Okay noted. I will be waiting for the shared results.

Regards,
Mellow
by
Hi,

I have sent you a private message kindly respond :)

Regards,
Mellow
by
Have sent you a couple of private messages and some documentation, please respond -  thank you.
0 votes
by

we are forwarding port 80 to 80 in lan and this does fix it you need to ssh onto device 

Run this script on CLI:

 uci set firewall.@zone[0].mtu_fix='1'

uci commit firewall

/etc/init.d/firewall restart

we are using firmware FW ver.: RUT2XX_R_00.01.14.3