7920 questions

9345 answers

15054 comments

12869 members

0 votes
61 views 6 comments
by
I have a TRB145, TRB14510XXXX, s / n: 1106572355, firmware: TRB1451_R_00.01.06.1, when wanting to update the firmware it tells me "The uploaded image file does not contain a supported format.", I need help to change the firmware and use vpn zero tier

2 Answers

0 votes
by
Hi,

You need to update to this firmware first before updating further:

https://wiki.teltonika-networks.com/view/TRB145_Legacy_FW_Upgrade_Instructions

EB.
by
When loading the firmware the device tells me "The uploaded image file does not contain a supported format."
by
Have you selected the right version? There are two choices and you have to select the one that is your model.

EB.
by
If you download the file to codes beginning with "TRB145 1: TRB1451_R_00.02.03.2_LEGACY.bin" for my team TRB1451_R_00.01.06.1.

You may review it by teamviewer, what you need to do is connect two siemens S7-1200 PLCs for data transfer between them, each PLC has an RS-485 port and the TRBs must be connected by VPN, can you help me with this, thanks
by
Hi,

Were you able to update your firmware version of TRB145?

EB.
0 votes
by
I followed the steps according to the information they sent me and it didn't work
by
Hi.

So your current version is 01.06.1 and firmware downloaded from here doesn't work for you? https://wiki.teltonika-networks.com/view/TRB145_Legacy_FW_Upgrade_Instructions

Could you send me a screenshot of the message you get?

EB.
by
This problem has been around for a long time, I've reported previously, maybe not well enough.  

So after doing it a few times, with a few months in between having to do it again and forgetting what I did last time, my new method was quite easy.

Use 7zip, edit the metadata.json file in the section for the trb1451-modem.ubi the sha1 is incorrect, so overwrite it with "3cde6af4c7d2c766c25e5fb77bd9d840339bff16" and save the file and it update the archive file.

Also this is the sha1 calculated by 7zip too.

I am assuming that the file is correct, because it is the same file in legacy bin files for the trb1411 & trb1421, and if it ain't updating it again with v2.06.1 afterwards anyway.  trb1401 has a different modem file.

Cheers Dennis