7662 questions

9091 answers

14654 comments

12054 members

0 votes
85 views 1 comments
by
I'm trying to setup RUT955 as act FTP client to upload the files to AWS server running vsftp. I'm able to ping the server from the modem.

I've installed lftp program, however when I try to connect to the server with the below command, I receive an error about libssl.so.1.0.0:

root@Teltonika:~# lftp -p 21 -u ftpuser 157.174.59.48

lftp: can't load library 'libssl.so.1.0.0'

This is strange as libopenssl is crearly installed which can be seen from commands below:

root@Teltonika:~# opkg install libopenssl

Package libopenssl (1.1.1k-1) installed in root is up to date.

I thought it might have to do with the service being disabled, but I don't see anything about openssl in the output of service list

 ls -l /etc/init.d

The only other thing I can think of, is some missing soft link (ln) in /bin/ or some other directory.

I appreciate the help.

1 Answer

+1 vote
by
Hi,

In the directory /usr/lib you'll find these libraries. What you have to do is copy the libraries and change their names that you're being prompted when executing lftp.

In my case I had to do this to make it work:

cp /usr/lib/libssl.so.1.1 /lib/libssl.so.1.0.0

cp /usr/lib/libcrypto.so.1.1 /lib/libcrypto.so.1.0.0

cp /usr/lib/libreadline.so.7 /lib/libreadline.so.6

cp /usr/lib/libncurses.so.6 /lib/libncurses.so.5

cp /usr/lib/libncursesw.so.6 /lib/libncurses.so.5

After I copied and renamed these libraries lftp worked normally.

Hope this helps.

EB.
Best answer
by
Thanks, this has solved my issue. Never would have though of it myself.