10948 questions

13055 answers

20356 comments

27897 members

0 votes
97 views 0 comments
by
I have a TRB 140. I have tried a manual reboot remotely as the modem is in the field. I have an issue where the eth0 port keeps stopping after a few days and am trying to find the issue. After manual reboot no reboot shows up in the system logs as with all earlier reboots. I have also tried doing an auto-scheduled reboot and this does not show up in the logs either. so not sure if modem is rebooting or not. when I can replicate the eth) problem I will report that.

1 Answer

0 votes
by
Hello,

Logs are fully wiped after reboot as these are stored in RAM.

If you find your TRB140 with less uptime than before - it definitely reboots itself as it should.

If you want to save the log right before the reboot, you could do scheduled reboots yourself with the crontab.

Here you will find enough information to configure it:

https://openwrt.org/docs/guide-user/base-system/cron

So basically what you want to do is to set a crontab for the device to save logs from "logread" to /etc/somekindoflog.txt just before the crontab of reboot execution.

Command for copying the logs: logread > /etc/log.txt

EB.